Can i use SSL provider and domain bought outside of InfinityFree?

I see the only paid SSL provider is GoGetSSL. But, can i include another provider? The same question for domain.
Also, do I have to manually update the SSL (even i buy GoGetSSL 5 year plan) every year?


While you certainly can use outside SSL providers, InfinityFree provides free SSL. Also, note that the control panel only support select certificates.


If you have a custom domain, you should use CloudFlare and get a self signed ssl from Infinity and use full ssl.

1 Like

Yes, I know about the Free SSL, and i’ve using them for a long time, the thing is I have to renew every 3 months…and i would like to never renew (i saw that multi-year plans can autorenew every year).

I’m here but i dont see cpanel asking for specific certificate

If you have a custom domain, you should use CloudFlare and get a self signed ssl from Infinity and use full ssl.
Infinity free also offers a free self signed SSL, but you have to add it to every browser in order to view your website…

Not if you’re using Cloudflare full ssl.

If the certificate’s common name is not the specified domain name, it will reject the certificate. This does not happen with premium, though.

thanks for suggesting…
After spending some time, i found this way didnt work with infinityfree… I got the error The certificate uploaded is NOT for the domain name (CloudFlare Origin Certificate was seen) .
But with some minor changes, this worked.

1 Like

Unfortunately i receive the error

redirected you too many times.


If i change my index.html with a simple one:


it works fine…
but my index.html has a redirection to a subfolder:
<meta http-equiv="refresh" content="1;url=mySubfolder/index.html">

and i get the redirects error…
The same website works fine with GoGetSSL free certificate and an domain…
Is there any chance it has to do with the Cloudflare SSL?

If you don’t have your SSL redirects set up properly, bad things may happen. Also, I recommend HTTP redirects (use PHP for that) over meta redirects.


It seems that your website is first redirecting from the home page to the page in the subfolder, and after that the redirect loop starts. Looking in that folder, there is a .htaccess file with an HTTPS redirection snippet. I think this snippet is causing the redirect loop.

If you’re using Cloudflare, my recommendation is to remove the .htaccess redirect for HTTPS, and just enable the “Always Use HTTPS” option in Cloudflare. Enabling that option also enforces HTTPS, but at the Cloudflare level.


I tried your suggestions but it couldnt work…

I tried the redirection with PHP instead of meta… and enabled the “Always Use https” in cloudflare…
also removed the .htaccess

It seems that the problem is to redirect to the subfolder…
redirect from index.php to index2.html works (same folder) but redirect from index.php to /subfolder/index2.html doesnt work…even if its a simple “hello” html page…So the problem seems to be the redirection to subfolder…

Can you share the code you use to redirect to the sub-folder?


$URL =  'https://'.$_SERVER['SERVER_NAME'].'/mySubfolder/index.html';

header("Location:  $URL ");


I previously had redirection with JS, but it didnt work also

This syntax looks like it could break. Maybe try header("Location: " . $URL);

Can you share any redirect/meta snippets from the index file in the sub-directory? Thanks!

1 Like

I tried the header change but still the same… But anyway it redirect correctly…i understand that the problem is after the redirection…

I checked the subfolder/index.php and i dont find any strange redirection…
Can these lines cause anything?

<script src=""
    integrity="sha256-/xUj+3OJU5yExlq6GSYGSHk7tPXikynS7ogEvDej/m4=" crossorigin="anonymous"></script>

  <script src=""></script>

But, if you wanna check yourself, here is the index.html under question…

Where exactly did you place the PHP redirect? I checked the base URL at, but that page is still using a HTML meta redirect.


i send just to show the index that doesnt work.
The link im having the redirection problem is
(both sites are the same content…but the second is the one that doesnt work)

I have checked, but that site has a completely different issue.

The big difference is that is using Cloudflare, and the redirect to HTTPS snippet you’re using doesn’t work (anymore) with Cloudflare.

If you’re using Cloudflare, I would remove the force HTTPS redirect from your .htaccess file, and enable the “Always Use HTTPS” setting in Cloudflare to redirect traffic to HTTPS.

This is why it’s useful to always point out exactly what you’re having the issue with. Not just a similar example, because if you don’t know the cause of the issue, it’s hard to know exactly what’s relevant and what isn’t.


i dont understand…i already have the “Always Use HTTPS” setting in Cloudflare enabled and i dont have any .htaccess of my own (just the default outside of htdocs)…
so where is the isssue?

The speech_2_dymo folder on your site contains a .htaccess file which contains a snippet to force HTTPS. If you don’t know or care about those rules, you can just delete that file.


That was the error! I finally fixed it…
the speech_2_dymo/.htaccess was there from a previous website where i had only this subfolder…so i forgot to check for .htaccess there…
Anyway…after deletion it worked like a charm! Thank you for your support!

1 Like