Almost a full minute page request responce time

Website URL =

Error Message = none

Other Information

My web site has almost a full minutes page request response time, it’s always been at least 30 seconds but now it’s even worse. I understand that my website is on a free hosting plan, but why would you guys make your hosting service look so incredibly bad. I sure hope your paid plans have a heck of a lot quicker page request response times. I didn’t complain about this issue until now because I just assumed your free hosting plans were geared towards forcing clients on to a paid plan by making the websites response times so slow that they would never get any traffic or search engine placement. But a full minute, come on, why even offer free hosting at that rate?

Your website loaded in 802 milliseconds for me (.802 seconds)

You have a WordPress website, so its WP-Cron that is slowing your site down. Whenever you don’t have visitors for awhile, the first person to visit will trigger every automatic update and check that WordPress wants to do before your website loads.

To help with this, disable automatic updates, and add your homepage as a cron job in the client area


Ok I turned off all the auto-updates, but I can’t figure out how to add my website’s homepage as a cron job. by chance do you have instructions on how to do that?

and thank you very much for the help :slight_smile:

This article explains how to handle WP Cron with our cron jobs:


I tried doing what the article explains but it appears not to work because it won’t let me edit or enter the address correctly, it forces me to use http: instead of https: thus the address for the cron job is invalid and will never run via the cron jobs feature.

Am I wrong or? I just checked again and the cron job shows no statistics. I have it set to run once every 15 minutes.

Just a heads up I tried adding the cron job from the vista pannel/cron jobs, I just tried from the account over view area and cron jobs and it allowed me to create a job via https: will let you know the results shortly.

Awesome thanks, when I added the cron job from the account over view/cronjobs area it worked fine. The attempt from the vista pannel cron jobs failed though and I removed the cron job from there.

Yes, please follow the instructions in the article. All the instructions and screenshots show the cron jobs tool in the client area, not the control panel. That’s because the one in the control panel doesn’t work very well, which is why we built our own independently from it.

So yes, please remove any cron jobs set up in the control panel and never touch it again.

1 Like

Thank you so much for your help :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.