Adding my site to cloudflare

Username (e.g. epiz_XXX) or Website URL

(hidden to protect privacy)

Error Message

I cannot add my site to Cloudflare, and I am really confused. I already added one of my sites to Cloudflare and it works. The website in question is (hidden to protect privacy). The error I am getting is:

Failed to lookup registrar and hosting information of (hidden to protect privacy) at this time. Please contact Cloudflare Support or try again later.

Other Information

I already looked at the Cloudflare documentation, but it doesn’t give a solution that works. I got my domain from

Clear your cache and try again. If it doesn’t work, you will have to wait a bit for Cloudflare’s systems to detect the domain.

I’ll try that, but I think the problem is the WHOIS lookup.

I think so as well

Sometimes I also got the error. But I tried clearing my cache and changed my dns nameservers. I also waited for the nameservers to be stable, like populate across every continent. Sometims I just point the nameserver to cloudflare prior to 5 hrs before adding in CF. Then add the records needed.

Which nameservers did you use? Also, I have waited 24 hours and still no luck.

Screenshot of the error:
(hidden to protect privacy)

I have it in Spanish so I can learn.

Your best beat would be to wait an hour or two. When was the domain created?

The nameservers assigned to your account. You can find these in one of your domain dns page in the bottom.

I created the domain 3 days ago.

I can’t get those if I haven’t added the domain. See the screenshot I included above.

1 Like

I was asking you to check in one of your other domains like you said. They are the same for your account(Nameservers)

Perhaps try contacting Cloudflare Support than. I tried to add your domain to my Cloudflare account and got the same error.


I should have searched the community like @Oxy did. Please ignore this and read the post below instead.


update: you did it - I see it is on CF now


Thank you. I’ll try that. Guess you can’t always trust Google search results :wink:

does that mean you didn’t add?

then someone else did it

TEST is here

Have not added yet. Requesting SSL certificate in hopes that I can add it as per what I read on the linked CF forum.

ok there are no more NS of CF because probably someone deleted it from their CF

I hope that CF will not block you because it can block you if you often add a domain in a short time

I removed the CF NS so I can request ssl. Don’t know if that’s necessary.

how did you know which Cloudflare NS to put in if you failed to add a domain to CF?

this process only goes later once you add the domain to the CF
you cannot arbitrarily put some NS of CF
but only that pair that Cloudflare generates for you during the process


Put SSL on my site, still can’t add it to CF.
The only NS on my site are and Same error message as before.
Can’t get WHOIS info from but I can from