Adding my site to cloudflare

Try forcing HTTPS. I kind of don’t know why your having issues, since I added a .ml domain from freenom quite easily to Cloudflare a few weeks ago.

Already did force https. I added another one of my domains to CF on Sunday (8/29). I don’t know how much more info I can provide or whether I should take this issue to CF.

Thanks everyone for your help and suggestions.

if it continues like this in the coming hours then contact CF support

1 Like

Apparently, this is a problem with Freenom domains. I think I’ll have to wait a few weeks.

1 Like

As far as I can see Freenom neatly returns your NS

I am not sure it really is a nameserver issue. It rather seems Cloudflare cant run the whois or whatever for some other reason and throws out an error

maybe you had double NS at the beginning (CF and our NS)
so when CF scanned for the first time , it saw that something was wrong
and now maybe it has that old data in the cache for a while and it doesn’t allow you to add a domain because of that

it’s even funnier because I use Cloudflare DNS (
and it neatly recognizes your NS and gets an IP and I can visit your site (file listing) without any problems through the browser.

be sure to contact support here
and let them explain to you what the problem is (ask for clarification in a nice way) .

1 Like

I have tried to create a CF support ticket, but it will only let me make one for my other domain. That means the only other option is to go to, and a topic like that has already been created:

I tried to use dig on my site (in WSL) and it worked 2/10 times. Using the link @Oxy provided returned everything, all looking correct.

While I was trying to add my site, it was banned for 3hrs because it thought I was a bot. During that time should it have cleared the cache?


You don’t have to delete anything because I assume that it is saved in CF DB (number of attempts) and not that it is stored in some cookies in your browser.

Tries to add a domain but fewer times in one day.

You can even try sending a message to the moderator there
and ask if they can forward your message to support because your access to them is limited
or you try to open a new message tomorrow.


you can also use ordinary commands from PS


I checked just in case and all of our NS (7 of them)
and they all return the correct (same) IP for your domain



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.