Account state corrupt?

Continuing the discussion from Various system issues (DNS, SSL, FTP, etc.) starting May 15:

Hi there, I have an issue which started during the recent outage:

  • I created a free account assigned to a free subdomain *
  • Domain didn’t get attached to account (because of iFastNet outage).
  • Assuming I did something wrong, I attempted to manually add the subdomain in cpanel.
  • I learned that there is a general outage and suspended further attempts.
  • Outage ended today, everything seemed fine, only I found in my account both addon domain and subdomain with the same name but different storage folder. SSL assigned but can’t be detected via browser and files can’t be accessed online.
  • Re-removing the subdomain makes my account lose any concept of domain - can no longer alter CName records or attach SSL.

Any idea how to restore my account state to have a single addon domain (in the subdomain form *, without a subdomain, and properly recognise throughout my account?

This is the expected state if to judge by my other two similar free accounts.

Um, I would delete the domain from everywhere in the client area, delete the hosting account, and create a new one and adding the same domain again.

1 Like

Was afraid of that :slight_smile: ok, will start erasing things and start from scratch.

Take a backup first so it is easy to re-upload! And you don’t have to delete the files, just the domain than the account.

Is all Online

I think he needs to delete his hosting account, so he needs to take a backup so it can be uploaded to the new account. It is not safe to keep everything online, because than a data failure can make you loose everything. You should ALWAYS keep a offline (flash drive) backup, so even if your computer fails you still have your files.


Your proposed solution will leave me without a website for 60 days :sob:

@Admin, other members, any other way to make sure I have a single, functioning sub-domain registered on my free hosting? Sounds like an operation that should be achievable via cpanel, without deleting and recreating an entire account, right…?

No, You just delete the domain first, than the account. As soon as you delete it, you can create a new account, re-ad the domain and re-upload your files. That is just saying the old account will not be deleted yes, but just deactivated (It needs to be that way for legal reasons).

1 Like

You need to make a backup see guide , deactivate your accoutn deleting domain, wait 60 days for deletion → Re-create the account and restore the backup see this post

@OverloadedTech, the problem is in the first post.

@Greenreader9 thank you, I could indeed re-create another account immediately when the “borken” one was deactivated.

I got most of it working, but I can’t seem to install the certificate I received earlier today (before the account recreation) for this domain. Does it need to be re-created? Domain name is identical.

Note: It’s not that I can upload the certificate but it isn’t trusted. It just doesn’t get assigned at all. I simply uploaded the private key and then the certificate, incl. the opening “-----” comments. I’ve tried with and without a closing CR/LF. I still get ERR_SSL_PROTOCOL_ERROR on the client.

If you still have the CNAME records setup, and you still have a copy of the Certificate and Private keys, No. If you don’t have one of those three, Yes.

I have set them all up identically.

(PS I was under the impression from the inifinityfree docs that for the SSL provider I’m using GoGetSSL the CName can already be removed after the certificate is issued. But I set it up as before nonetheless, just to make sure.)

Hm, that’s kind of weird, but using Cloudflare can fix that.

A Full Guide To Cloudflare - Community Guides - InfinityFree Forum

1 Like

Thank you, but I’m not interested in setting up Cloudflare. My other two accounts here work just fine with GoGetSSL, I’m hoping we can make the third one work the same way as well. Any insight would be appreciated. Please let me know if there’s any additional information I can provide to help resolve this.

Ok, you may just have to wait for Admin than.

@Greenreader9 lol its then

but @tsemer just do what you did with the other 2 :slight_smile: it will still be the same! there is not really any other additinal help we can give you :slight_smile: so contact and admin but please dont @ them :slight_smile:

Of course, that’s what I did so far - the same as the other 2 :slight_smile: problem is… it doesn’t work. Which is why I’m suspecting the original iFastNet issue may not be fully resolved.

Hmm I did indeed tag the Admin on the other thread to get their attention in case there is still some outage… is that supposed to be bad form?


Technically, yes. But you did not know better, so all is :ok_hand:

1 Like