502 Bad Gateway nginx


502 Bad Gateway


Hi,I know there are many topic on this issue, I’ve already spent hours reading through and there’s no solution relevant to my issue. I get this error message 8/10 not only when visiting the site but even during editing my site on wordpress.

Thank you.

Hi and welcome back to the forum! Your website does indeed take a long time to load, which makes me suspect it’s pretty heavy and as such is more easily causing a strain on the servers, resulting in getting 502s or similar issues.

I can see you’re using both WooCommerce and Elementor, which are both very heavy plugins and are not recommended to be used on free hosting, especially combined, as they can reach its limits pretty easily and result in suspensions (or errors, as in your case).

The advice in a similar issue applies:


Hi thank you. I use Bosa Storefront Theme. Woocommerce and other in support of the theme and elementor.

1 Like

Hii. My website faces a lot of 502 Bad Gateway errors whenever I visit my site, or even click on something on my site.


What is your website?
If it’s also using WordPress, it’s probably related to the issues I mentioned above.


Is there any other possible issue, I’m getting different types of errors on admin mode?

İnfinity free servers running apache amigo. Try disabling cloudflare proxy on your domain.

Now I get blank page. Can you please check for me if everything is correct on the server. I’m so frustrasted.

I don’t have cloudflare

Yep, I just checked and your domain directly points to ifastnet.

However, upon hecking content of empty page of your site, I’m pretty sure it’s either an extension error or corrupted wordpress files.

  1. Please turn on error reporting on visa panel.
    Go to your hosting account on dash.infinityfree.com and continue to control panel. In PHP Config seciton, alter php config of your domain and turn on error reporting.
  2. Allow wordpress to show errors
    Go back to your hosting panel, dash.infinityfree.com and this time go with file manager. Continue to htdocs of your site and edit wp-config.php. You have to change wp_debug define to true.

This time, when you access your site it will tell you what components are broken. IMO your script gets terminated because of lack of memory.

  • Additionally

There’s nothing you can do about 502 error. My suggestion is just in case if problem is a different thing. 502 error means ifastnet Burried Down their servers which means infinityfree GG

Not necessarily. It could also mean high load (Like in a DDoS attack).

That’s not going to be helpful with a 502. As the server would have stopped the request, the website does not exactly have any say in what is sent as a response to the client, with a few exceptions.

@Hoemie, your website is loading perfectly fine for me. Could you share a list of all of the WordPress plugins you have installed?


I thought in case if his php script throwing the error for fun

it was broken yesterday. body tag was empty. Great if its fixed.

Still isn’t going to help with it, it is always going to end up with 500 if there is an error and display errors is disabled.
If it throws 502 “for fun” then it means there was no error to prevent the php code from execution at first place.


head tag was filled but body was empty. So im sure code execution started but cut off.

Hi Everyone, it gives different errors. "This page isn’t working

zeusslago.com is currently unable to handle this request.

HTTP ERROR 500" is the current error, at least it needs me to reload the page twice before it loads correctly.

Plugin: Advance Import, Big File Uploads, Bosa Elementor Addons and Templates for WooCommerce, Breadcrumbs Navx, Contact Form, Elementor, Keon Toolset, Kiki Customizer Framework, Prime Slide, Newsletter, SMTP, Email marketing and Subscribe forms by Brevo, Shortimage optimiser, Woocommerce, Sina Extension for Elementor, Variation Swatches for WooCommerce, Woocomerce paygates…

Ok, that list of plugins is most certainly behind the errors. Both Elementor and Woo are huge plugins, and all the Addon plugins are also have are likely making things way worse.

Free hosting does not even meet the minimum hosting requirements for Elementor, so it’s highly recommended that you don’t use it (Use the default classic editor instead).

Also, remove as many other plugins you have. The more you remove, the faster your website loads, and the less likely you are to get errors.

Don’t disable the plugins, delete them.

Also, disable automatic updates.


Deleting them only frees up inodes / disk space.
Disabling already prevents the plugin from loading and makes website faster.


That’s why it’s recommended over simply disabling.