ZeroSSL keeps resulting in "SSL certificate error: An unknown error occurred. Please try again later."

Username (e.g. epiz_XXX) or Website URL

epiz_26669064 -
epiz_27910743 -
epiz_26669064 -

All three exhibit the same behaviour.

Error Message

“SSL certificate error: An unknown error occurred. Please try again later.”

Other Information

Look like you’ve upgraded your SSL request process (looks nice!) and added support for ZeroSSL. Kudos :slight_smile:
Infinity now tells me that ZeroSSL is a bit better than GoGetSSL because of “Easy renewal without new validation”. So I give it a try.

Setting CNAME went fine. But all three domains go from:


I retried a few times for each domain, but same results.

I tried now issuing and installing a certificate from GoGetSSL (which I’ve used so far) for, and this worked fine. Still, I’m curious to try the new service for my other two domains. Any ideas what I should try? Or perhaps the problem is on ZeroSSL side and I should just try again tomorrow?

Welcome back to the form @tsemer!

It sure sounds like a ZeroSSL configuration issue.

Admin will look into it when he comes online and will hopefully be able to let you know what happened.

1 Like

Thanks @Greenreader9 :slight_smile:
Quick update: I tried it again this morning, same result.

Hi :wave:,
This is some sort of bug with the SSL tool for ZeroSSL. I tried this morning :sweat_smile: and it worked, the records were same.

Very strange. Going through the logs, the problems seems to be in part that ZeroSSL is taking a REALLY long time to validate the domain name, and the third party library we’re using to talk to ZeroSSL doesn’t deal with that in a way that makes it easy for me to work around that.

I’m working on rewriting that code to prevent this from happening, but it’s big and complicated.


I think you should use cloud flare for SSL certificate …

@rssquirelsoftwares, OP can’t do that because these are free subdomains, and Cloudflare is only available with custom domains.

1 Like

He could Just get a free domain from Freenom and then transfer all files to that domain (after setting up with infinityfree)


after creating site (with custom domain ) he can use cloud flare free SSL certificate (don’t forget to see the tutorial) . or He can get a third party ssl certificate (free/paid) .

1 Like

Please note that Cloudflare Certificates do not work here, since the control panel does not accept CA chains. The SSL generator was not working earlier due to a DNS issue, but it running properly now.


Thanks for all reactions and friendly suggestions! I appreciate them.

I already have a viable workaround (GoGetSSL), so I suggest to keep this thread streamlined:

Let’s just follow admin’s cue as to whether we can get ZeroSSL to work within infinityfree.

FYI, just tried again, result is still the same error as in my original posting.

If admin (or anybody else) can provide reproducible steps that make ZeroSSL work, please post. Otherwise, let’s leave cloudflare and any other alternative solutions for other threads :slight_smile:.


As per Mr. Admin :sunglasses:, he/she clarified that the issue was fixed. Maybe try clearing your cache once? None can reproduce cuz we are no owners of the client area!

1 Like

I know there were some DNS issues before causing SSL errors, and ZeroSSL needs a reconfiguration to work properly for everyone. In the meantime, both GoGetSSL and LetsEncript are working alternatives.

@jaikrishna.t, can you please clarify where Admin said it was fixed? He said that the code needs to be reviewed. Additionally, one can reproduce the error just by requesting a certificate!


I think here? ==

1 Like

Thanks @jaikrishna.t. I can only assume that the issue admin mentioned in your reference post and the issue discussed in this post are two different issues: Admin analysed the former as time based and the latter as code based. Additionally, I can still reproduce the error.

As a side note, I can’t imagine that any caching mechanism is affecting the SSL creation chain. Ultimately, the underlying code must be sending a brand new web request to ZeroSSL each time you trigger it, with some pretty basic input. But I haven’t seen the code so I may be wrong about that one.


@jaikrishna.t, that post describes the DNS issue, not the code issue. There is still an issue with the code that is calling ZeroSSL’s API, as Admin said earlier.

@tsemer, I agree with what you said about caching. This is not a caching issue, but a code issue on Infinity’s side.

Other SSL services are still running just fine, only ZeroSSL is having a few issues.

Please let me know if you have any questions!


Update: I’ve been trying it once every day, and today it worked, for both of my other domains, within a few minutes :grinning: so either ZeroSSL fixed some latency on their side, or Admin managed to fix the code on Infinity side. Either way - ZeroSSL now seems to work fine. So cool, good job, and thanks!
Thread can close :heart:


Yep, Admin has fixed them, glad to hear that it is working!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.