WP action scheduler not working?

I’ve installed a wordpress instance from your control panel, all generall well however when I set the plugins to auto-install, the install isn’t happening and I’m getting this:

Is this expected behaviour? It’s a pretty vanilla install, nothing special. I presume these updates are run through WP-CRON, as is action scheduler. WP-CRON should run on page load (not via CRON), so not sure why these actions aren’t happening. Any ideas?

It isn’t recommended to let them auto upgrade, nor upgrading muliple plugins at the same time, as this can easily broke the execution time limit.


I believe all forms of cron are not available on free hosting


The WP-CRON would fire at every page load if DISABLE_WP_CRON isn’t defined as true.


Please read


Yes it will trigger but I do not think any cron job can run as it is no longer available on free hosting.

This is the reason why OP had that notification


Why wouldn’t a PHP script fire if I just call it with something like require_once script.php?

Naming that script wp-cron.php doesn’t affect anything, what do matters is the execution time of that script, which may go over 30 sec and gets killed.

This is why you don’t enable auto upgrade for all your plugins, as when the CRON fires it checks and may upgrade all those plugins, and usually end up with a failed upgrade.


Thanks @Frank419 , there aren’t that many plugins, so execution time limit isn’t an issue in this case.

Thanks @KangJL but it’s not a cron job, it’s a PHP script called WP-CRON which is supposed to be triggered on page load.

It’s even stopping the setup of some plugins from working properly which is quite annoying. I’ll take a look at the page you recommended, thanks again.

You could try opening the wp-cron.php URL yourself, both to see if it works and to move the cron jobs along.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.