Wordpress site transfer issue

Hi, I an transferring my Wordpress site from another host to Infinityfree. I have imported my database from my old host and copied all the contents of /htdocs to my PC. I have changed the nameservers and installed Wordpress on my own domain (formulaspec.com.au).
The default ‘Hello World!’ wordpress site loads fine when I navigate to formulaspec.com.au. When I copy my old site files over the default Wordpress ones (including modifying wp-config.php to point to the database I have imported) the site on longer works. the error is: " formulaspec.com.au is currently unable to handle this request. HTTP ERROR 500 "
Is there something I have missed or could the problem possibly be the Wordpress version is different (newer) than the version on my old host? Thanks in advance

Hello there,

Please check this Knowledge Base article first if you still haven’t:

1 Like

Thanks, that’s very helpful, now I get a series of errors which suggest my problem might be the old host had /public_html as the root directory and epizy has /htdocs. I guess I need to either rename /htdocs to /public_html on my new host or go through the files (database?) and rename /public_html to /htdocs?

Warning : file_exists(): open_basedir restriction in effect. File(/home/nicktrev/public_html/wp-content/uploads/2020/05) is not within the allowed path(s): (/php_sessions:/tmp:/var/www/errors:/usr/share/pear:/home/vol6_8/epizy.com/epiz_25690664/formulaspec.com.au/htdocs) in /home/vol6_8/epizy.com/epiz_25690664/formulaspec.com.au/htdocs/wp-includes/functions.php on line 1602

You don’t need to rename stuff, you’ll just have to make sure that your WordPress files are in the /htdocs folder and make sure that all your wp configuration files has the correct address.


OK, I’ll give that a go soon, first I’m trying a new host because Infinityfree no longer supports ma


Note that you don’t need to change your website hosting if you just want an email service. You can pair a free email hosting service (like Zoho) with our free website hosting service. You don’t need to find a single service which does everything.

1 Like

Hi, I tried using improvmx email forwarding service with Gmail. It works well but unfortunately I can’t use epizy custom nameservers because to set the MX records to improvmx I need to use the DNS hosting option at my registrar. so since I chose DNS option my website no longer works, it says "This domain name is currently parked "
I tried using the website IP address for the A records anda CNAME alias but it hasn’t worked, have I done the CNAME incorrectly?:

Our DNS controls are quite limited, but we do support custom MX records. What made you think it wasn’t possible?

The CNAME record is done correctly, the A record is not. The A record points to an IP address which we don’t own, which is probably what’s serving the parking page.

Please lookup the IP address to use and set that one on your root domain.

Or, if you don’t feel comfortable managing your own DNS records, please move your domain name back to our nameservers and set the MX records there.


I was able to receive emails sent to my domain with this method of setting MX records but not send

I changed the A records to the IP address ( returned from Google dig too for my main domain (echtq7ck.epizy.com). this didn’t alter the website behaviour, it still says “This domain name is currently parked” I guess that could that be coming from my registrar’s nameservers?

MX records never affect sending email. So whatever the issue is you’re having with sending email, there is no way it could ever be caused by your MX records.

An MX record controls which server should receive email on behalf of your domain. Nothing more, nothing less.

As far as email sending goes, from where are you trying to send email? In your screenshot, I see you’re using ImprovMX. But as far as I know, they forward incoming email only, don’t they?


Apologies, the A records took 36hrs to update so now website is working fine. ImprovMX have instructions on using Gmail to send from your domain by using a TXT record, which I guess was the problem with custom nameservers. thanks again for your help, it is all working fine now

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.