Wordpress not recognising SSL

Website URL


Error Message

Several. One of them: “The certificate is not trusted in all web browsers. You may need to install an Intermediate/chain certificate to link it to a trusted root certificate. Learn more about this error. The fastest way to fix this problem is to contact your SSL provider”.

Another: " This site/page has used all avaialble php / apache processes allowed on free hosting account.

Refreshing the page once the amount of apache / php processes are reduced will cause the site to work

We would recommend upgrading your hosting account at IFastNet Premium hosting accounts , premium hosting accounts have MUCH higher resources dedicated to them."

Other Information

This is mainly about my SSL. It was issued a few days ago and it says SSL certificate is active. When testing it through writing https:// in front of my url, it works. In general settings in WordPress, I have changed my website url from http to https (upon which all fonts on my website changed, magically :frowning: ) to force visitors to the secure version of the site.
The padlock which I got initially when the SSL was issued is now gone and WordPress claims that my website is not secure and I have no permission to alter some things, like navigation for instance.
When I try the SSL checker (sslshopper.com), it says that the “certificate is not trusted in all browsers”. However, I found a post here on the forum that said the above error message can be ignored and that it doesn’t make any difference so I have ignored it.

At the same time, I get the second error message (going back and forth from dashboard to the site, mainly). In the forum I found an article that says “The short answer is simple: there are too many requests being executed on your account at the same time.”. But my site is new, I have no visitors, VERY little content, and essentially no plugins. There is nothing there.
It also says " Ensure static files (like HTML or CSS files) don’t have the .php file extension." I have no idea what this is or how to ensure this. How do I figure out if I have any php-files?

That was a lot of questions, should they have been in two posts? I didn’t know, thought they might be related somehow. I hope you don’t mind. Thanks!

You have a trusted certificate installed, you can ignore wherever you saw that



WordPress may be trying to run a bunch of background tasks, which can also trigger it. Disable auto-updates, and any cron tasks you created.

Also, note that bot visits (Including crawlers like Google) also influence this.

WordPress is created in PHP, so you have a ton of PHP files. This note is more for people who custom-coded, and does not apply to you.


OK thanks.
So in essence:

  • The certificate is ok, wordpress should work. ** Question: If it keeps on not working, is there anything else I could do? Cloudflare?**

  • Get iFastNet Premium if you want to avoid the apache message, what I get now is to be expected. ** Q: am I to expect to get this error message only during the site build or will that happen to myself and visitors after the site is up? Apart from a subscription - is there anything else I can do to ease up on the php/apache thing?**

  • I have a lot of php-files, but I don’t have to worry about it. Apart from disabling the auto-updates. ** Q: Should I disable them for ever or just now that I am trying to build the site?**

The SSL shopper checker will keep saying the certificate is not fine, but for almost all uses cases, it is. I would suggest to just ignore the SSL shopper message.

If you don’t want to: then indeed Cloudflare, or premium.

This seems to be caused by Mixed Content errors: the links to the fonts on your site use HTTP, while the page is loaded over HTTPS. Modern browsers refuse to load such links for safety.

Usually, changing the site URL in WordPress does the trick, but any custom code, or advanced website builders, may require additional changes to make it work.

The error is caused by too many concurrent requests. I don’t know, and don’t have any way to know, what exact behavior triggered it. But it’s largely influenced by concurrent activity to your site, so it could happen as well after the site is published. But it’s basically impossible to say at this point.

The error is caused by too many concurrent requests. Upgrading to premium gives you a much higher limit. The other option is to reduce your usage. As for how to do that, there is no clear cut answer on how to do that.


Thank you for your insightful answers! One more thing: You are saying that the page is loaded in https while the fonts in http. How do I change that? Deleting them and installing again? Any other possible way? Or am I simply out of hope here? I have installed them - in Wordpress - through the plugin Custom Fonts.

I don’t know exactly how to fix it. I can only see that it is caused by this code on your page:

<style id='cf-frontend-style-inline-css'>
@font-face {
	font-family: 'Adrianna Extended';
	font-weight: 400;
	font-fallback: Montserrat, thin;
	src: url('http://echo.co.com/wp-content/uploads/2024/03/AdriannaExtended-Thin.ttf') format('truetype');
@font-face {
	font-family: 'Adrianna Extended';
	font-weight: 400;
	font-fallback: Montserrat, thin;
	src: url('http://echo.co.com/wp-content/uploads/2024/03/AdriannaExtended-ThinItalic.ttf') format('truetype');

The actual list of fonts is much longer.

As you can see, all of these URLs start with http://, which should be https:// instead.

I’m not familiar with the Custom Fonts plugin, but it’s absolutely possible that it’s responsible for this code. And removing and re-installing the fonts may fix this.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.