WordPress Issue

CDN Error
I am trying to use the “LiteSpeed Cache” plugin to fix the page cache error which is listed in the Wordpress Site Health troubleshooter.

This error indicates something about another plugin using the “REST API”??? Or perhaps a list of IP addresses need to be AllowListed? I can’t find reference to any of these options.

Is your recommendation just to forget about these couple of small “issues” in the Site Health troubleshooter? It did not “seem” to be affecting my site at all. I just don’t like looking at errors each time I login. Is this feature not available with the Free Hosting option at Infinity Webhosting Servers? Every other option has met my needs so far with this service. :slight_smile:

Please read

2 Likes

Website URL

https://artisticwebsitesolutions.web1337.net/wp-admin/admin.php?page=kubio&postId=41&postType=page

Error Message

Warning : mysqli_real_connect(): (HY000/1203): User if0_36745128 already has more than ‘max_user_connections’ active connections in /home/vol6_2/infinityfree.com/if0_36745128/artisticwebsitesolutions.web1337.net/htdocs/wp-includes/class-wpdb.php on line 1987

User if0_36745128 already has more than 'max_user_connections' active connections

Error establishing a database connection

This either means that the username and password information in your wp-config.php file is incorrect or that contact with the database server at sql311.infinityfree.com could not be established. This could mean your host’s database server is down.

  • Are you sure you have the correct username and password?
  • Are you sure you have typed the correct hostname?
  • Are you sure the database server is running?

If you are unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress support forums.

Other Information

I have tried editing the WP-Config file with the MySQL Database configuration information, but with no success. I have made a backup, in case I screwed something up. Please help?

Please read

2 Likes

Website URL

https://artisticwebsitesolutions.web1337.net/wp-admin/post-new.php?post_type=page

Error Message

Other Information

I have had a spade of issues with this web hosting tonight. I have a feeling it is related to the MySQL database somehow. I have tried re-installing various plugins, and they have all given me a range of problems. This is just one of the errors that I have encountered. Please help.

Check this out. See if will resolve the issue

https://www.google.com/search?q=updating+failed.+you+are+probably+offline&oq=updating+failed&gs_lcrp=EgZjaHJvbWUqBwgBEAAYgAQyCQgAEEUYORiABDIHCAEQABiABDIHCAIQABiABDIHCAMQABiABDIHCAQQABiABDIHCAUQABiABDIHCAYQABiABDINCAcQABiGAxiABBiKBTINCAgQABiGAxiABBiKBdIBCTkzMTBqMGoxNagCCLACAQ&sourceid=chrome&ie=UTF-8

2 Likes

I went into the General Settings of the Site and changed the https:// protocol back to http:// even though I have a SSL Certificate installed for my site.
The site still seems to redirect http traffic to https… This has fixed the “You are offline” error, but now I have the original error message back!

"
Warning : mysqli_real_connect(): (HY000/1203): User if0_36745128 already has more than ‘max_user_connections’ active connections in /home/vol6_2/infinityfree.com/if0_36745128/artisticwebsitesolutions.web1337.net/htdocs/wp-includes/class-wpdb.php on line 1987

User if0_36745128 already has more than 'max_user_connections' active connections

Error establishing a database connection

This either means that the username and password information in your wp-config.php file is incorrect or that contact with the database server at sql311.infinityfree.com could not be established. This could mean your host’s database server is down.

  • Are you sure you have the correct username and password?
  • Are you sure you have typed the correct hostname?
  • Are you sure the database server is running?

If you are unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress support forums.
"

I have triple checked the WP-Config file… I can’t seem to see any references to either http or https in the WP-Config file… I have gotten my Username and password for my WP-Config file from the MySQL Databases section of your website, but I am not 100% sure I have this correct either. This is really driving me batty, as I have another site with the exact same plugins on the exact same webhosting, and I am not having any issues like this.

Is it possible that the subdomain (xxx.web1337.net) is not compatible with the SSL Certificate? Or perhaps my MySQL Username and password fields are not quite correct in the WP-Config file?

Also, I have two MySQL Databases. Is this normal? I am connected to the w976 one, do I need to delete the other? I have tried this, and both deleted when I removed just one…

Can you tell that I’m just wingin’ it? Lol
When everything works smoothly, I will be set. :slight_smile:

Sorry _wp976 … That one! It is copy and pasted into my WP-Config file, so it is correctly named there. The fact that I am connected to the database, and hitting the Max User limit, tells me that the User and Pass are correct? Am I correct in thinking this?

The max_user_connections error means that your database credentials are correct and you’re (probably) connected to the right database. However, as the error message implies: there is a maximum number of simultaneous database connections per database user, and you see this error because your website is trying to use more database connections than are allowed.

In short, this can be caused by too many database connections from your code, or too many concurrent requests. The too many database connections from your code is most often seen with custom coded website that sometimes create a new database connection for every query, instead of reusing the same database connection. But with WordPress, that shouldn’t be an issue, unless you have a really poorly coded plugin or theme.

The too many requests issue can be caused by having too many concurrent visitors, or too many requests being fired by the visitors, usually due to runaway background requests. Judging by the fact you see this in the editor, I suspect it’s the latter. If so, you may try to disable some plugins or switch the theme and see if it helps, or maybe setup a caching plugin.

4 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.