Wordpress install stuck at 95%

Website URL


(please specify the URL of the site on which you are experiencing the problem)

Error Message

Installation of wordpress not moving more than 95%
(please share the FULL error message you see, if applicable)

Other Information

(other information and details relevant to your question)

Try to go back to the Softaculous home page and then retry the install again. It should work after that.


Try install it again…!

Tried it @HELPINDIA , it asked for override, I checked the box as well and did an re-installation.

Uninstall it and remove any previous databases or files in your htdocs directory that were created by the previous installation attempt. Then go to Softalicious and try to install again.


Hi @solace-ken ,

Tried deleting the files under htdocs folder, did a reinstall but its still stuck.

One possible issue is that you selected https:// and the error says “A trusted SSL certificate was not found”.

You should either install it on http:// or install a SSL certificate for your domain and then try again.

Already have an SSL Certificated installed and its active

Also tried with http:// installation as well.

Hmmm. That’s strange that it shows this error.


I did some looking around and found these threads here:


The people having this problem seem to refer to database issues. (e.g. database is too large). After you uninstalled WordPress you removed your previous databases?

One guy suggested this:

Another potential issue could be related to the size and complexity of the imported data. If you’re importing a large amount of content with numerous attachments, the process might take longer, and a timeout could occur, resulting in the stuck import.

Another guy said:

I left the same database there, but:

a) Selected ALL tables
b) TRUNCATED all tables (the “Empty” option on the dropdown in PhpMyAdmin)

Restored, and it FOR ONCE, did not hang at 95%.

Previously, I had tried with the existing database (which, in my case, with some plugins that were causing issues).
I also tried by renaming the database so the restoring one might work … no go.

So I think that emptying out the tables to avoid my issue (duplicate index in PRIMARY) did the job.

I don’t know if these are relevant to your case. But, I’m not an expert on WordPress installation. I’m just searching around looking for answers. Other people have reported this issue with Softaculous and WordPress too. They seem to think it’s related to the database size or plugins. I don’t know. I’ve never encountered this before. Someone who knows more than me will have to chime in and help you troubleshoot this problem.

Did you read this FAQ here already?


@solace-ken Is there a specific step to delete your database, am not sure if i did that, the only thing i would have done is delete all the folders in the htdocs file, would that count as to deleting your database, if not can you please let me know the steps to check and do that if not done?

I think you mean these Databases right? under phpmyadmin?


Hi, you should be able to go to Control Panel > MySQL Databases to remove them.


@solace-ken I dont see any Databases in MYSQLDB, can you help.

If you don’t see any that means that there are none. That’s good. :+1:

Now you can do the new install. The installer can set up a new database now.


@solace-ken no luck still stuck at 95%, let me check the other threads you had shared to see if it works.

1 Like

At this point, you may be better of with just removing the domain from this account, and creating a new account for it.

Clearly something is going wrong here. It could be a server problem or an account level corruption, but it’s clearly not easy to fix.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.