Wordpress does not send emails

I have my WordPress website and I have installed contact form 7 + wp mail SMTP, the configuration is correct but it does not send the form emails, nor the WP mail SMTP test emails. Is there any extra configuration that needs to be done on the hosting?


There was a problem sending the test email.

Your SMTP account could not be identified.
This means that we cannot connect to your SMTP server, so we cannot proceed using the email/password settings.

Normally this error appears when the email or password is not correct or it is not the expected SMTP server.

Recommended next steps:
Double-check your SMTP settings, including your hosting address, email, and password. If you have recently changed your password you will need to update the settings.
Contact your SMTP server to confirm that you are using the correct username and password.
Verify with your SMTP host that your account has permissions to send emails using external connections.
Visit our documentation for additional tricks on how to resolve this error.


Please contact your SMTP provider for assistance with this one, as it seems the problem is on there end, or with your configuration of their services.


If I remember correctly, we only allow port 587 for SMTP. So please set the encryption type to TLS and the port to 587.

If it still doesn’t work after that, please verify that your SMTP credentials are correct.


I just changed the settings, but it still won’t be working for me.
The SMTP username and password credentials are correct because you use them to access the email, but it still does not work.
I have no idea what could be causing this.
If you can think of anything else I would appreciate it.

That doesn’t have to be true. The SMTP server name could be different than the IMAP, pop or webmail address. And even if the address is correct, the credentials could still be rejected, either because your email service uses different credentials for it, because something went wrong and the credentials are not working, or another reason entirely.

One thing you could try is to see if you can send email using these exact credentials using a different email client. A desktop mail application like Thunderbird would do the trick.


I sent a test email from Webmailfereo to a Gmail email and the email arrived correctly.
It seems to work well, but I still can’t find the reason why the emails are not being sent.
On the other hand, the corporate email service has told me that everything is configured correctly for it to work, so the truth is I have no solution. I don’t know what to do…


I’m sorry, I should have been more clear.

I meant that you should try sending a message from a different SMTP client. Like a desktop email client. Webmail credentials are not necessarily SMTP credentials, the SMTP sever name may be different or may be restricted in the first place.

Neither do I. It’s your website talking to your chosen SMTP provider. There is only a very small part which we can influence.


There I was testing the SMTP credentials on the page SMTP Test Tool and they work for me with the
server: c1801917.ferozo.com
port: 465
SSL: yes,
and the second configuration that worked was
same server, port 587, encryption: none.
Will ports 465 and 587 be closed?
Because if not another explanation I can’t find.

For the SMTP credentials, use the same ones as to enter the email, in this case, they are the same because I did not change the password and it worked correctly.

The debug of the Easy WP SMTP plugin gave me the following result, maybe it can help find what is happening

Your screenshot mentions only the backtrace, the error should be right above. Can you post that?

As mentioned above, only port 587 is supported.

Have you tried that on WordPress? Your screenshot above had “encryption” set to TLS, not “None”.


Yes, I try both configurations all the time to see if one works. but so far they didn’t work

I setup a little port testing script on your account that tests whether the SMTP hostname and port is reachable: http://mrpro.rf.gd/_port-test.php

This scripts shows that the connection works and isn’t blocked. The message “SMTP Error: Could not authenticate” could mean anything: ports, protocols or credentials.

So whatever the issue is, it’s clearly not a server block on our end. So you’re going to have to figure this one out with your email provider, because we cannot do anything about this.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.