Why the home page show mixed content when visiting the websites by moibile

Website URL


Error Message

skip to content, please refer to the attached screenshots below

I’m not getting this issue.

Since you mentioned “by mobile” on the title I assume you’re not getting this issue on desktop? This is very likely a caching issue. Try clearing your browser cache or visiting via a different browser.


Hi Chris,
Yes, no issue on the desktop. May I know if you aslo tested by mobile? I just typed “Convergence.cf” on Google, then was showing this mixed content. How can I clear browser cache on mobile or visit another browser? Also, I am concerned if visitors also encountered this issue.

Here are some 5xx console errors found out by the theme provider, they asked me to inform you as well as to fix them, please find the attachement. Thank you.

I’m not seeing any issue

(Safari on iOS 14.6)

Please try visting the site on different browsers and networks.
Also,sometimes ssl could be nasty,and result in rich contents not loading.So try visiting your site over http(If you have forced https then disable it temporaily).
Please tell if the issue persists.


If you’re on Android, you can follow these instructions (make sure to select only the “Cached images and files” option, not cookies which the article suggests unless you also want to clear the cookies):

If using iOS, you can probably find a similar article online.

If you don’t have one installed, you can download one from the Google Play/App Store.


Hi Frank,

Regarding the http/https issue, I have tried to redirect via cPanel, but doesn’t work (see below).

In addition to using .htaccess based on your request. However, it caused the website to be broken.

RewriteEngine On
RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteCond %{HTTPS} off
RewriteCond %{HTTP:CF-Visitor} !{“scheme”:“https”}
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Therefore, I have no idea how to do that, please advise.

Thank you

Yes. I don’t know why the redirects tool lets you create a redirect like that in the first place, because it will just create a redirect loop.

Can you please explain a bit more about what happened? What broke exactly and how did it break? What did you see?

It’s easier to fix the issue if we know what it looks like.


Both websites are loading securely for me now, and are forcing HTTPS.

Is that what you see on your end?

1 Like

Hi Chris,

Thank you for providing the related details.

After cleared cache & cookies as instructed, the issue still persists. Perhaps it related to http/https (see the attached screenshot), right?

Also, the featured image option is not showed up. Please find the theme provider’s advice.

"Most likely this is a server issue. Maybe ask your host to increase your server limitations.

In general, the following are the recommended values:

  • the PHP memory limit set to 512MB
  • the max post size bigger or equal to 50MB
  • the WP-memory limit 128/256 MB
  • the max upload size 50 MB
  • the max input vars 2500
  • and ideally the max execution time should be around 300."

The issue is showing on Google, not Chrome when visiting the website by mobile.

Hi Greenreader9

Thank you for your assistance.

The mixed contents sometimes show on Google (see below), using Chrome is much better.

As per forcing HTTPS, could you please teach me how to do that? As I have other websites to do so as well as I would like to cancel the self-certificate showing “unsafe” (see below)

It seems to me that this is an issue with the theme, so please ask the theme developer to optimize their code to reduce their system requirements.

Who is right? Is it a server issue or a code issue? That’s a matter of opinion.

But what I see is a mostly static site. It shouldn’t take a lot of power to run. It shouldn’t need half a GB of memory per request, which then takes 5 minutes to run. But that’s exactly what those limits demand. And I don’t think that this is acceptable. I think that the system requirements of Elementor are unreasonably high and that the error is with them, not with us. But I’m sure that they think their expectations are reasonable and that we should just provide more server power.

In any case, servers aren’t free, and so there is only so much we can give you for free, which is not enough for Elementor. So your options are either to find/buy bigger hosting, or stop using Elementor.


Dear Sirs,

I used Kadence theme for all websites they are currently encountering this issue. Convergence.cf has Elementor but Delicious-food.cf doesn’t have. Once deactived all plugins the featured image option shows or activated the Kadence theme plugin still shows. If activated Kadence Block plugin or others then the Featured Image was not showing up.

OK, I may have gotten some of the details wrong, but I think my general point still stands. Requiring half a GB of memory and 5 minutes to be able to show an image on a page is not reasonable in my opinion.


Dear Sirs,

As I am a beginner, not familiar with this. Could you please let me know how to fix it? That means you or the theme developer can do so, please explain the issue you found with professional solutions if you advise.

I expect to receive your response with solutions promply because my clients are chasing me to fix right away.

Once again, thank you for your assistance and sorry for any inconvience caused.