Why IMAP/SMTP is not working?

Hi there, I’ve noticed that SMTP or mail server is not working on my hosting and I don’t mean like webmail I’m talking about mail transfer service on my website. My wordpress contact forms aren’t working and my WP system can’t send system emails to admin email. If you know anything about this issue please let me know in the comments, thank you!

I think you know more about this issue right now than anyone else.

In order to fix that, can you please share:

  • Which SMTP provider are you trying to use?
  • Which SMTP plugin in WordPress do you use?
  • Does WordPress show any error messages when you try to send email?
  • Did the SMTP integration work before and did it stop working, or are you unable to set it up at all?
  • How do you suppose IMAP is related to this issue (IMAP is only for reading email, not sending)?

Hey Admin, that’s the thing I’m not trying to use any 3rd party SMTP service what I’m asking is don’t you guys have it running already? Every server setup for hosting providing purposes usualy have SMTP working by default to my knowledge. And yeah thanks for the info I’m not a guru about this server stuff I wasn’t sure if it was IMAP or SMTP.

We don’t provide an SMTP service with our hosting. Most SMTP plugins should just work here, but only if you have your own SMTP service to connect it to. A free Gmail account can be used quite well for this purpose.


Thank you I’ve figured it out with Zoho and Sendinblue, now let’s hope that MX records will work. It’s been more than 6 hours but still no change in MX records.

1 Like

Where exactly do you see the MX records have not been changed? Please note that any DNS changes can take up to 48 hours to take effect.

We can also check whether your MX records were set correctly, but we would need to know your domain name to do that.


Well I’m sure I’ve set them correctly I’m an ex web designer&developer so I’m not that newbee on this stuff but I didn’t know it was 48 hrs tho I thought it was 24 hrs. Anyways let me wait for an another 24 hrs and I’d let you know if something goes wrong, thank you for your support Admin.

Hi Admin, it’s been more than 60 hrs and still no change in MX and SPF records, I’ve also checked w dnschecker.org no results in there either. What should i do?

Maybe post your domain name so we can check?


It seems like your domain is using the Cloudflare’s cPanel integration, which breaks MX records and subdomains. If you want MX records to be working again, you can disable it and add the domain manually on Cloudflare instead of using our integration.


Thanks a lot pal!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.