Why can't I add my domain?


Your domain is not yet pointing to ns1.epizy.com and ns2.epizy.com. Change your nameservers at your domain registrar and wait a few hours. You can also create an account with a subdomain first.

A few days ago I changed the DNS and waited two days but it didn’t activate. Yesterday I tried again and today I get the same error.

Can you help me?

No, you did not

Unfortunately, your domain will not work on free hosting


Immagine 2022-01-22 135834

I entered the required DNS as shown in the figure. I can not do anything else.

The .it is a gTLD that doesn’t work on free hosting. Sorry!


Like our domain checker says: you need to check your nameserver settings, or as your domain provider for help.

Our domain checker tool simply looks at the nameserver records being returned by the .it registry servers. If those don’t return the right values, then your domain name will just not work.

It can happen that the settings you configure through your domain registrar aren’t applied to the registry nameservers. This can be caused by a technical error at the registrar or registry, or by restrictions being placed on your domain name. Whichever of those two it is, the people at your registrar should be able to help you with this, and tell why your settings are not taking effect.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.