When viewing my website it only shows directory listing and no pictures

Hi, I’ve uploaded all my html files from dreamweaver to the htp folder via ftp.

When I clicked to open the website on my computer it was showing the homepage for great-site (great-site.net > Related links > Free Ecommerce web store > Build my own mobile app… etc)

I read the forum and deleted the file index2.html from htdocs as suggested.

When I open on my phone it just shows Directory listing and the files saved in HTdocs. I can click the links and all the text shows but the pictures show.

My home page is saved as homeindex.html. When I open on my computer it still shows the great-site home page even though I’ve cleared my DNS cache.

Please help how do I get my website to open on the home page and show the pictures properly?

My site is cakesforallspecialoccasions.great-site.net

Thank you

Try add these to your .htaccess (create one if not available inside htdocs):-

Options -Indexes
DirectoryIndex homeindex.html


Index file must be named as “index”, if you just want to set the index page…then just rename homeindex.html into index.html, but if you want to disable directory listing too you can achieve this with .htaccess file.


Security wise, it is better to disable directory listing…you do not want your website to be hacked


Thank you. When I view on my phone’s browser it now shows the home page. But it’s still not showing on my computer for some reason.

Pls clear the cache on your computer browser.
Also mark this issue as solved


I’ve done this but it’s still not working.

It is working on my end.
Can you try to refresh your browser?

1 Like

It working properly on me too, maybe try to clear the cache?

1 Like

Hi everyone thank you all so much for your advice and help :slight_smile:

I think it may be something to do with which browser I’m using as I did clear all the caches but still didn’t change anything. Chrome and Microsoft edge it doesn’t work, but it does on internet explorer, though all my formatting isn’t there.

Do i need to add the CSS to the htdocs folder also?

No harm trying…

1 Like

Probably. Your HTML page references the CSS file http://cakesforallspecialoccasions.great-site.net/css/singlePageTemplate.css . Taking a quick peek at your account files, I don’t see any CSS files there.

And of course, you need to upload your CSS if you want to use it on your website.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.