Website not working....(Sub-domain working perfectly..) [Solved]

Help Me… (SOLVED)

i have created a website in infinityFree. but the matter is not working my website. my all subdomains working perfectly . i did understand what is the problem . I have been using this website for several days. But the domain is no longer available today. i don’t know why my sub-domain only working perfectly ??!!
My domain is provided Godaddy, so i contacted them to solve, after they check it , say that

“contact your hosting support team , this is the problem of your hosting provider”

Error Message

when open , show me

This site can’t be reached

server IP address could not be found.

If i open my sub-Domains, it working well!


hosting provider : InfinityFree
Domain Provider : GoDaddy
SSL Provider : InfinityFree

*If you want to know more , ask me

i have removed and re-added my main Domain, but website still not working… Its worked well, my website working well
All thanks dedicated to @anon53753884 @anon19508339 @KangJL

Could be due to DNS caching. Please wait up to 72 hours.


I have been using this website for several days. But the domain is no longer available today

Not sure then.

1 Like

@Admin Can you help here

1 Like

Hello* @Admin Iam waiting for your Great Solution !

Admin is himself busy with real life issues, If he was available for helping everyone everytime, he wouldn’t create support forum.
@AdYouWebs For your main issue I suggest you to remove your domain from control panel then add it again since i assume DNS records for that domain name are corrupted.


@BayoDino that is possible ,but the issue, iam installed wordpress. if iam remove domain i couldn’t retake that datas to wordpress !!

You can, just remove your domain name then add it back, ADDING OR REMOVING DOMAIN NAME won’t affect hosting files


i think, if iam remove my domain from cpanel, all the data in the Filemanager will be removed !! am i right ? or ?

NO. Don’t believe me?


ok thanks, i will try to do !!

Can see there is indeed some hosting issue
as only subdomain is able to resolve IP but not main domain.

1 Like

As i mentioned above v

it should be fixed by re-adding the domain.


Hope @ AdYouWebs had performed Wordpress backup…

1 Like

No, i didn’t take backUp for my wordpress

You shd always backup before doing anything else, just to be safe.
If your Wordpress was installed using Softaculous, it will be quite easy to create a backup

1 Like

Could there be some issue with the main domain?

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.