Website not working. Connection is not secure. Even after installing SSL

Does your .htaccess have these?

<IfModule mod_rewrite.c>

RewriteEngine On

RewriteCond %{HTTPS} off

RewriteRule ^(.*)$ https: //%{HTTP_HOST}%{REQUEST_URI} [L,R=301]


Thanks for the reply. Yes.
The redirection to https seems to work now, but the “really simple SSL” plugin keeps giving me the warning, maybe I can just ignore it.

I needed to set the HTTP_HOST manually to my domain
Any idea why could that be?

It has to be else it would not work…

FYI .htaccess Cheat Sheet - All Rules You Will Ever Need, Listed On One Page for Apache .htaccess Server Rules

1 Like

I see. I thought that the variable %{HTTP_HOST}% will return the url of my website.

It should…

I recommend not tampering with the .htaccess and just use really simple SSL, it will do it all for you.

Thanks for replying.
On the “really simple SSL” plugin website there is an article that talks about the matter. They said that if the default .htaccess settings are not working then you should either use WordPress 301 redirect or edit the .htaccess file manually.
So I did the latter and it seems to work, however, I needed to insert the domain name manually.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.