Website Not Working after changing nameservers

I just change my nameservers to the SSL providers, ‘Cloudflare’. After that my website stops working.

From this KB article, but fixed:

First, delete all DNS records currently in Cloudflare’s DNS page for your domain. Then, you’ll want to add the following DNS records:

  • CNAME record with name @ and the target being your account’s main domain. How to find your main domain.
  • CNAME record with name www and target @ .
  • MX record with name @ , target and priority 10 (to receive emails).
  • An additional CNAME record for every subdomain. So if you have a subdomain “blog”, you need to add a CNAME record with name blog and target @ .

After that, set the SSL option to “Full” in the SSL/TLS page if it was set to “Full (Strict)”.


First, you have to change the name of the file “home.html” to “index.html”… in the File Manager.

Now It shows your directory listing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.