Website not up in search engine

I have a domain and use your free hosting service. I updated wordpress theme newspaperX but the site is not showing on search engine.

You need to install the Yoast SEO plugin in WordPress, then configure it via the configuration tool and add your domain to the Google Search Console by adding a string of code on your header.php file using the Theme Editor on WordPress. It’s even better to add CloudFlare protection to remove ?i=1 from your URL and add HTTPS (or SSL) to your website.

Hey, Thanks for your response. But I have not enough knowledge to complete your instruction. can you help me to do the process.

I have installed yoastSEO plugin and activated

For the Yoast SEO installation: go to your wp-admin, click Plugins, then Add New, search for “yoast seo”, install it and then enable it. Then you should go to the Yoast SEO logo and you should see a notice to start the configuration wizard. Go through it and follow the instructions.
For CloudFlare: You can use either the cPanel integration (but it breaks the subdomains and MX records) or go here and sign up. If you’re using the second method, follow me:

  1. Add your domain to the domain field and click on Add Domain. Select the Free plan and continue with the DNS. Then go to your Freenom Domains section, to your domain, click on Management Tools and then Nameservers and put the CloudFlare nameservers in place of the InfinityFree ones.
  2. After adding CloudFlare nameservers, reload the page and make sure the SSL option is set to “Full”, not to Flexible, and wait from 1 minute to 24 hours to the SSL certificate to be issued. After the SSL certificate was issued, you can access your website through HTTPS and change your URL in WordPress to point to the https version of your website.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.