Website not loading from Airtel connection

My website address is
Hosted on infinity free. The same problem is happening with me but the thing is that only on airtel connection. Every other data connection showing my website running properly but with airtel connection it says error in Websites not Loading showing error DNS_PROBE_FINISHED_NXDOMAIN
What to do help in this matter as soon as possible.

Please don’t hijack other people’s topics to ask your own, unrelated question. For this once, I split the post to a separate topic. Next time, it will be flagged as off topic and deleted.

As for your question itself, did you try asking Airtel about this? If every other connection in the world (including my own - I can see your website) can access your website but one provider can’t, maybe this is an issue or restriction at that specific provider?

We don’t block access from specific providers, so I’m quite sure this is an issue on their end and not ours.

1 Like

I am not hijacking other people’s topic .I feel that this is the most suitable topic according to my problem because i am unable to find the exact topic related to my problem. i feel sorry for that. i have contacted about that service provider but they are saying that it’s not our fault. The major users uses that particular network in my country itself. So that this arise a problem for website. Hope you understand my concern. What the wrong is going on i am not able to understand.

I read the topic again, but that topic is quite clear that a domain name stopped working everywhere suddenly. There was also a fix in the topic. The error message was the same, but the other symptoms were clearly different. And if the solution provided in the topic was confirmed by the original author to work and doesn’t work for you, that’s quite strong evidence that your issue is different.

And when in doubt, please create a separate topic (but feel free to reference the other topic).

I’m not entirely sure what the issue is either. To my knowledge, this isn’t an issue on our end either. But it has to be an issue somewhere, or it would just work.

But the error message does indicate that your computer is unable to find an IP address for your domain. There are a variety of reasons why this could happen, so we can try some things to figure out what’s happening.

Could you try to switch your device’s DNS resolver to another provider, like Google or Cloudflare? This will help rule out any issues with the DNS resolver of Airtel.

You could also try to see if you can resolve the domain name directly from your own computer. On Windows, you can run a command like nslookup to check the status of your domain on our nameservers.


I have tried all this but nothing works. Still having the same issue.

Can you also please share the output of the nslookup command?

1 Like

I have Airtel connection too and its showing me your website on both PC and Smartphone. Maybe try clear cache data I’m not expert but sometimes it works for me when i delete cache data if some website is not loading.


Thank you Saurabh for checking my website. You are able to access my website through airtel connection but i have tried from several airtel connection in more than five devices and in each device i am unable to access my website and I tried all way like changing ip address, clear cache and site data everything but still unable to access my website. I feel good when you said you are able to access my website because i have tried and i take several people reaction that your website is not accessible from airtel connection. Can you tell me one more thing that you easily access my website without clearing cache or you do something else for it.

I did nothing just simply copy paste your URL in chrome and its working fine and normal like all other websites are.

1 Like

Okk thank you.

Here the nslookup command

Very interesting, thanks for sharing the results!

It looks like your computer is unable to connect to our nameservers. This could be an issue with the connection to our nameservers, or some kind of block on the domain. My gut feeling says it’s the latter.

Could you try to run nslookup instead? If it is indeed a problem with the domain, that should work. If you can see the IP address in the output, that means the command is working.

If that last command is successful, you can change your domain’s nameservers from and to and Those nameservers return the same records as the ones, but allow you to circumvent any connection issues with our domain.

Thank you for pitching in @Saurabhmittal. If you are also on Airtel and it just works for you, maybe it’s not an issue with the Airtel network?

Do you run any sort of virus scanner @SMboss on your computer? It could be that the virus scanner blacklisted the domain.

1 Like

Okk but how can be virus scanner is blocking all the devices like computers, smartphone and my friends device and their airtel connection only and same device access my website from another connection. I don’t got it.

It was just a guess. I wasn’t aware that the issue affected smartphones too.

Nevertheless, can you please try the alternative nameserver host like I talked about?

On doing several reasearch and changing ip address i come to know that fortiguard web filtering blocks my website.

. Now what to do help me in this. And if you can do it just do it.

I think you’ve found the answer as to why you cannot load the website. If you or your network administrator are using FortiGuard to restrict your web traffic and FortiGuard says your domain name should be blocked, then you cannot access your domain name.

In the screenshot is a link through which you can request FortiGuard to recheck the page. You could try to ask FortiGuard to verify your website is not “in violation of your internet usage policy” (whatever that may mean).

Although, as far as I can tell from your screenshot, the only reason FortiGuard has blocked your domain is because it’s a “Newly Observed Domain”. I can see where they would be coming from, as many harmful domains are generally newly created and more established websites have older domains. But IMO using that argument to blanket ban all new domains is a very pedantic and biased approach to security.

So if you have any influence over the decision, I would recommend to stop using FortiGuard entirely. I would never want to use a tool which such a narrow minded idea of website safety.

1 Like

Yes you are right but i am not using this tool but the airtel network itself uses this tool that blocks the newly constructed domains i have written to them but they are saying me contact your IT manager or administrator so i don’t know whom do i contact?

Your IT manager is the person or team responsible for your network. If you are on a school network or company network or something like that, there is probably a person or service desk internally who can help you with network issues. If this is a home network and you are the network administrator, you should contact your ISP (so: Airtel).

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.