Website is secure on android but NOT on desktop

hi all, today i purchased a domain (see above) and i use the cloudflare option in the vista panel.

i don’t have an error message but i have something weird… on my mobile device (android, using chrome) i get a padlock (secure site). that is what i wanted to do…

but with desktop and every browser possible i still get the “not secure” with the i.

Other Information

i bought my domain dynadot and used the nameservers from epizy to get it to work with infinityfree… and the only way i can get ssl to work is with the “flexible” option.

hope this info helps

Your SSL is working fine on my end, try clearing your browser cache (F5).

Just a tip, the Cloudflare option in the cpanel can break your site so I recommend using Cloudflare from here:


could you “please for me” explain in detail how to do it because i got a “suspended domain .org problem” once already

Explain in detail what? Nothing of what I said will get you a suspended domain, don’t worry.

no i know but i tried adding it directly to but i cannot get it to work that way…

i used the A - @ record directing to {MY-INFINITYFREE-IP}
and the A - www record directing to {MY-INFINITYFREE-IP}

This is correct.

You need to add a CNAME record instead of an A record.

if i add a CNAME record with the ip i get this error “DNS Validation Error (Code: 1004) Content for CNAME record is invalid”

the content for your CNAME record should be

i also suppose i change the nameservers form epizy to the cloudflare ones i got?

Yes :+1:

it now gives me this error:

Enable Flexible mode instead of full/strict.

If you want Full/Strict, then use InfinityFree’s SSL tool here:

it is, i only have two recored (the a record pointing to @ with my ip, and the CNAME record wit www going to

Looks good, your website works fine with ssl on my side.

again my phone is working perfectly fine now with ssl but edge, chrome and brave browsers on my laptop aren’t working (not even with cleared cookies cache and by doing ipconfig /flushdns in cmd)

Well, It might not help it, it might be DNS cache at the dns server, which you have no control over. Just wait :slight_smile:

i’ll wait for a bit then, think i’ll check back tomorrow and if it is fixed ill mark

@Technical.Legendz 's post as solution because he pointed me to the CNAME record instead of the A record…


hi @HaydenANG and @Technical.Legendz, i’ve waited for almost 24 hours and it has worked for an hour or so… but now it still shows not secure on my laptop (and my phone says it is secure) i also tried to set up the full strict version but infinityfree is not recognizing my two CNAME records (added them within cloudflare, does this work??) or do i need to change nameservers once again and just use the CNAME records within

this has been such a difficult process for me that i might be tempted to switch hosting platforms just for ssl because i might swap to wordpress and accept logins so i need the ssl (though i still want to give this one more try before i go)

i also noticed another small problem, because my site only answers to “” it ignores the .css when i enter “www.” in front of this, anyone have a solution for this because i’d love to get the full url [https://www. enterdomainhere .com]

this happens when i enter