Website is not serving from CloudFlare

Website URL :

My domain is registered from National Domain Registar as a country domain.
My Website is hosted at InfinityFree. Once I tried to enable cloudflare on my website, I am having an issue. As suggested in the other related topics on this forum, I try enabling the cloudflare from the cpanel. But the problem is I am aready registered on the cloudflare with that gmail account. And when configure from the . It says active.


But it is not serving from the cloudflare. Also when I try to ping my website from windows cmd with


It replies


I believe it should ping to cloudflare servers. But its pinging to infinityfree and not getting anything back.
Please help! What am I missing here??

Hi there uniksk I have to encountered this problem but also did not know how to fix it what I did is created a brand new account deleted my connected domain from my old account to my new one then activated cloudflare. It worked for me might not work for you though.

You mean create another infinityfree acount with non-registered cloudflare account and then enable cloudflare from the cpanel??

This link shd help…


Your domain is indeed active on Cloudflare’s nameservers.

But in Cloudflare’s nameservers, you’ve directed the domain to our servers with a DNS Only record. If you click the grey cloud icon next to the DNS record, it will turn orange to signify that you’ve actually enabled Cloudflare’s website services on that domain name.

Our servers block ping by default. This is not a problem, as you don’t need ping to access a website. Ping statuses only tell you something if you know that the host should reply to ping, which is not the case with our servers.

And as to why it shows our IP and not Cloudflare’s, see above.


When I was playing with the cloudflare DNS settings , I found out that the cloudflare features such as Cloudflare SSL , caching, Analytics ,etc will only take place if I proxied the record. They will not work during DNS Only . But when I proxied them, my website will go down saying Too Many Redirects.
How this thing works??

Here’s my current DNS Record.

Read this…


I am not using wordpress. I am with Laravel.

Same principle applies. You need to set your env file to http not https.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.