Website images not working

Images using tags are not displaying

Other Information

I’ve moved a website to but the images will not display correctly. I’m using Filezilla to transfer files, including images to the site. In troubleshooting I find that if I move a known good image to the website, then copy it back to a different directory, it is corrupted in some way so it can no longer be opened.

Any help would be appreciated.

1 Like

I inspect your site and I found that there is error in your script.

Upload your images via custom files uploader which will be in your Filemager.

I tried uploading the main page and the first image using the built in uploader rather than Filezilla. When I downloaded the image using the built in downloader, the problem persists. When I download and try to open the image file I get an error message: “We can’t open this file.”

I made some progress, but still have some more to accomplish. When I forced Filezilla into binary mode instead of auto or ascii mode, I got one picture to work. Unfortunately the same technique has not worked with the other three pictures.

Would you mind if you share the error logs?

No. I don’t mind. Please do share them.

However, I would like to point out that this web site works as (errors and all) on another web host and the pictures display there. The root problem seems to be that the .jpg files are somehow being corrupted when be transferred to the site. It doesn’t matter whether I use FileZilla, the built-in upload, or command line FTP. With one exception that happened to work (at the bottom of the page) the files cannot be opened at the website.

I’ve run an html checker and found the significant number of errors. I will deal with those later. Let me simplify the problem:

I’ve uploaded 4 files:

Despite repeated attempts from 3 different clients only one of the files eventually arrived at my epizy site intact. All others cannot be opened so it appears they were corrupted during file transfer.

Any help would be appreciated.

Thank you.

Solved: Apparently, the images were somehow corrupted just enough that they would open in the Photos app but not on the web page. I still can’t fathom how uploading them to my epizy web site and back down changed them so that Photos could no longer open them.

The fix was to open the damaged file with GIMP, export it as a BMP file, open the BMP file with GIMP, export it back to JPG and overwrite the original file, then upload it again.

Somehow this cleansed the jpg file of whatever corruption it had and it all works now.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.