Website host not showing images..?

Username (e.g. epiz_XXX) or Website URL

Website in question -

Error Message

There are no error messages, however the images on the sites does not appear, when i try to copy image adress they just appear as a box and the image is gone. Is this a problem with the host and how could i fix it? I asked in the MyBB discord for support and they said it would def be the host that had the problems because of the box that appears when you copy image adress.

Other Information

Hosting a Forum with MyBB, has images in the correct folders and everything, even tried with 2 different hosts & tried with 2 different versions for MyBB to make sure its not the download that is corrupt. Anyone able to help with this? Would be very happy if there were a fix for this. :slight_smile:


Firefox is telling me this:

The image , etc…

cannot be displayed because it contains errors !

when I download the image and try to open (on the OS) with some image viewer
it report the same

Try uploading again and check if the images are healthy before that.

A problem may also occur during upload as well as the act of storing it on disk by the server.

unfortunately I can’t tell you anything more


I have sadly already checked and they are indeed healthy, I can open them on my computer and everything but whenever i upload it through the filezilla client they break, I get the same errors when i try to download them… Could it be a problem with Filezilla? Cause I doubt its a problem with this host as i’ve seen others succeed with uploading their forums WITH images.

Viewing source of your image returns me this:


IHDR;Ö•JIDATxcÀþ3Ð¼Í£6㣕••éê²QŽ	a:fwnIEND®B`‚

This is indeed corrupted, have you uploaded so many images/files to your website? Or can you just use the web based filemanager to upload the image?

Did you tinker with the FileZillla settings at any point? Usually FileZilla works quite well out of the box, but if you start messing with transfer types, file encoding and those kinds of settings, you may just be bringing more errors onto yourself.

BINARY vs. ASCII transfers are something that comes to mind. FTP has different transfer modes, and FileZilla normally does a good job of determining the right transfer type. If you try to upload an image with ASCII transfer, that might cause the corruption.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.