Website got randomly erased (Suppose to be used as an admin panel)

Main Domain (According to cPanel) (Takes to suspended domain)

Although my actual domain works. (

Error Message: N/A

Other info:

I opened up my website about to do some web development, but when I went to it was blank, took me to the directory listing.
Logging into the file manager and my emails, I did not receive any notifications about deactivations or anything like that. It has nothing in it, apart from htdocs folder. Yes this did have things in it. There isn’t even the .htaccess file

I had a password protected folder in there called other. ( which had the reset password pages, and development pages I was testing out.


… is it even possible to do that? Just what kind of classification does this domain fall under, is this a sub-subdomain? Is this even a valid domain!?
And I tried going there but I’m greeted with SSL_ERROR_INTERNAL_ERROR_ALERT.
Also Main domain isn’t even used for internet purposes, not sure as to what it serves for.

The SSL error is because of my ssl certificate I am in the middle of setting up, it is a sub domain, it could be because I connected to a FTP viewer and it got hacked or something.

Uh… but you are already using a subdomain, so it can’t be one. can’t be because is one. Ok, now i switched to http. It is blank. Did you check the FTP site again and upload something to it to see whether it has something in it? (All files must be uploaded to /htdocs/_

I even tried creating and adding files, but remains. The work I had there is all gone. I had no backups. And it is, because is under as the actual domain, blockvio then the free

I’m going to let this just sit and wait for the Admin, or others who might be able to answer it. Its weird that it won’t show up even though you have the right permissions to create files.

Don’t think you understand…? I had files on there that were working fine, as soon as I connected to a FTP viewer other than the one in cPanel, the next morning it was all gone from and it seems the .htaccess is still taking affect redirecting to https?

No, I can confirm the .htaccess died now. It didn’t try redirecting.

Files that are gone are permanently gone. Unless you hv ur own backup…

I know that, but I am posting this just so admin knows because it can be a serious bug and I don’t want it to happen to anyone else. But thanks.

1 Like

I don’t know what happened. It could be a system issue, it could be an accident by you, it could be someone else with FTP access or it could be a bug/vulnerability in your code allowing hackers to delete all the files. I don’t know what happened and I have no way to find out.

All I can recommend again and again is to ALWAYS keep your own backups. An issue occurring causing data to be lost can happen for many reasons. But loss of code and therefore time and effort is entirely preventable.


Thank you for your reply. I will do this in the future. Like I said in a previous comment. I logged into FTP via a third party apple AppStore app then next morning this happened. But yeah thanks. The only bit I got from the internet was a bootstrap menu system I was testing out.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.