Website down after installing free SSL certificate

My website URL is:

What I’m seeing is:
You cannot access this site. The IP address for this site could not be found. ERR_NAME_NOT_RESOLVED

And when I put in I get ads.

Additional information:
The website was working fine on cloudflare, using their SSL. But when it was on ‘full SSL’ I had this problem . When I set it to ‘flexible SSL’ I had this problem. So I had to change from cloudflare SSl to the SSL provided by InfinityFree.

To do that I needed to set the CNAME records. So I deleted all the existing CNAME records (which were pointing to cloudflare), and set them as instructed. I received the SSL certificate. Then I removed the site on the cloudflare website. At the beginning I got a message that the site is not secure. Then after a few minutes I got the message above, that I cannot access the site. This was over 24 hours ago.

Any suggesstions? Thanks in advance!

It looks like the DNS records for your domain got corrupted. Can you please try to enable and disable Cloudflare again on your domain? That may kick your DNS records enough to restore the domain name.

We’re seeing a lot of reports like this lately and we’ve still not be able to fix them. But we’re working on it.


Thanks for that.

What does it mean they were corrupted? Was that caused by the InfinityFree SSL CNAME records? And did enabling and disabling cloudflare help for other people who had this problem? And should the website work again while its on cloudflare?

Yep, that’s what I know at this point.

All I know is that many issues like these started to appear when people started to use more CNAME records (for the free SSL certificates). But it doesn’t seem to happen to everyone, and to the people to whom it did happen, Cloudflare got mentioned quite often.

The goal is not to enable Cloudflare, but to prod the DNS settings in such a way you can enforce the creation of the right DNS records for your domain. The Cloudflare control panel integration also touches those records, so toggling Cloudflare can fix these settings.


Thanks for the advice. I did it, and (after a few days) the site was back up. But it came up as insecure i.e. the free SSL wasn’t working, even though it shows on my client area as active. Is there anything I can do about this?

Please note that getting free SSL on your website involves three steps:

  1. Getting the SSL certificate.
  2. Installing the SSL certificate on your hosting account.
  3. Configuring your website to use HTTPS.

The client area can tell you whether an SSL certificate has been created, but not whether it’s installed and used correctly.

Please see this article for more information about how to install the certificate:

And this article for what to do after that:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.