Web site down 80%+ of the time, only advert JS loads

Username: epiz_29032948
Web site: http://tldmaps.rf.gd/

Since registering the site a week or two ago, it only shows up briefly then disappears again. The first 4-5 days after registering, tldmaps.rf.gd domain would not even resolve. Since it has started resolving, it has been down 80%+ of the time. I’ve only seen it working 3 times, and it’s down again right now. When I connect to the site using a VPN, it usually displays the site. Friends who have connected to the site have also said it has been frequently down. It looks like major network issues, or an overloaded server on InfinityFree’s end.

There are no error messages. When the site is down it loads the advertising Javascript, but not the actual web site content.

Since it is working for me, it is probably a cache issue. Clear the cache on your device, and ask your friends to do the same. It should begin working afterwards.

I have been using Ctrl+Shift+R to reload the page without using cache. It makes no difference.

Cache issues can’t explain why the site keeps appearing and then disappearing at random since the site has been posted. The web site IS loading fresh from the Internet, but it only contains InfinityFree Javascript. I have also used wget to manually download the site (no cache involved in this downloader) and it has only the Javascript showing.

Here is the entire content that is delivered to my IP address by InfinityFree (HTML/Javascript), as of 5 minutes ago:

As I said, when I use a VPN I am usually able to see the site. In the same web browser that shows me only the Javascript without a VPN. If there was a cache issue, then it wouldn’t work over a VPN. InfinityFree is having major networking or software issues with my web site, the issues are not on my end.


Yes it does. Caching is usually the cause of these types of issues.

Open the inspector tab and make sure the “Cache” checkbox is checked.

That is the description of a cache issue.

It would work over a VPN because the ISP and server location are different

I disagree. Your website works fine on multiple device, and multiple networks by me. Have you tried a cellular device on a cellular network? Please clear your cache and cookies the correct way and let me know if it works.

This could also be happening to you though:


1 Like

I have over 20 years experience running an IT business. I’ve been creating web sites since 1994. I know whether a connectivity issue is on my end or not. You’re talking to me like I don’t even know what a web browser cache is. I assure you, I know what caches are.

“Please clear your cache and cookies the correct way and let me know if it works.”

Yeah, I know how to load an uncached page. Thanks. That’s not the issue. As I said.

I have tried loading the tool with Ctrl+Shift+R which is the correct hotkey in my web browser, Vivaldi. I have used this shortcut 100s of times while developing web sites, I know it works. “To do a hard reload of the page (without loading content from cache): Ctrl+Shift+R” From: https://help.vivaldi.com/desktop/navigation/address-bar/

The issue is not with my browser cache, it’s with InfinityFree’s DNS servers or other network software/hardware.

I have also loaded the page in Microsoft Edge, which produces the same HTML code as the pastebin. I have also used the tool “wget”, which I mentioned above. wget is not a web browser, and it does not cache anything, it only downloads things. I routinely use this tool to check web sites, as it easily spits out the full HTTP headers, including redirects and error codes. When I download the “tldmaps.rf.gd” URL with wget, I get what I pasted in the pastebin. Nothing but InfinityFree’s Javascript and sparse HTML code.

“I disagree. Your website works fine on multiple device, and multiple networks by me.”

Then you’re not very good at tech support, because the issue is not on my end. If it was a browser cache issue, then using a VPN *would not fix the issue as it would still show the wrong cached page. If you use logic, you can easily see that it can’t be a browser cache issue.

As for your link to the InfinityFree ongoing issues page, thank you, that actually does cover my issue – an InfinityFree issue where newly created sites were not having their DNS synced properly between InfinityFree servers, leaving some ISPs with the wrong DNS information. As I said, the issue is not on my end. It affects multiple Internet connections, multiple people, multiple browsers and downloaders. You saying the site loads for you is not helpful when it comes to InfinityFree DNS issues. DNS issues play out differently for different DNS servers, it’s not just one DNS server involved. Your linked page clearly says InfinityFree bugs messed up the DNS information for some ISPs.

I will try removing and re-adding the site and see if that helps. But it is a free “rf.gd” domain and not my own domain, so I’m worried if I drop it that I won’t be able to reclaim it afterwards.

1 Like

“It would work over a VPN because the ISP and server location are different”

That’s not how browser caches work. Using a VPN can not work around any web browser cache issues. It could work around router or ISP caching issues, but my router and ISP do not cache web pages. VPNs change the IP address and DNS servers, they do not affect how a web browser caches content. Cached files are local to the computer, if a cached file exists and hasn’t expired then the browser will use that file instead of connecting over the Internet to retrieve the current content. This was clearly not an issue with browser caching.

And I though I mentioned this…


Take note we are only volunteers, not professionally paid tech support.
This is free hosting, not paid hosting. That is why we have a community forum here

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.