Using Infinityfree for subdomain

I want to use the free hosting from infinityfree for my subdomain only, ai.lancarin.id, not the main domain.
Currently, I am using the default nameserver from my domain registrar, and added these NS records for the subdomain in DNS manager.
ai NS 3600 ns1.epizy.com
ai NS 3600 ns2.epizy.com
But, the page still won’t load. I have not made any changes to my DNS records, but last year, it was working fine. The infinityfree site, however, went dormant, so I just reactivated it again a few days ago. Somehow, it’s now not working. What should I do to fix it?

I think you supposed to add A record, not NS. First, are you sure you configured the ai subdomain on your hosting account?

2 Likes

Yes, already did that.
I’m not sure if the image shows correctly here. I have A record added (I think i added this when I first used Infinityfree last year). Is there anything else that I’m missing?

image

Another question, is it possible to change the address back to the free subdomain from infinityfree instead of my own subdomain? How do I do that?

Actually, I see this message:

ai.lancarin.id is not using InfinityFree nameservers!

Any settings shown or configured here will not affect your domain name.
To use these DNS records, please change your domain’s nameservers to ns1.epizy.com and ns2.epizy.com.
The current nameservers of your domain are: ns1.idcloudhosting. com, ns2.idcloudhosting. com.

So, having these NS records alone is not sufficient in my DNS manager?
ai NS 3600 ns1.epizy. com
ai NS 3600 ns2.epizy. com

From the picture you seem to be putting A record correctly, but your domain uses idcloudhosting nameservers at the moment, and that nameserver is having problems with either bad horizontal referral or lame delegation error message. Since you’re on custom domain, you may try switching nameservers to cloudflare.

In reality you can’t put NS record to a subdomain :slight_smile:

2 Likes

In theory it should work. The lancarin.id domain is using the nameservers from idcloudhosting.com. But if you then query the idcloudhosting.com nameservers for ai.lancarin.id, then their nameservers delegate it back to their own nameservers at idcloudhosting.com, not epizy.com.

I can’t tell from my end whether you configured the NS records correctly, or whether the operators of idcloudhosting.com are just not publishing the records correctly.

In any case, please contact your current DNS provider? They should be able to tell whether you’ve configured it correctly, and whether they’ve published the records correctly.

Sure you can! The DNS for infinityfree.net is hosted with Cloudflare, but acmedns.infinityfree.net is hosted on a different set of nameservers. This is also what allows things like eu.org to work.

5 Likes

Actually, I read in another post earlier, when they used Cloudfare, someone mentioned that you had to change the nameserver to epizy first, to verify the domain, then, change it back to Cloudfare nameserver after. Maybe it has something to do with that?

But, if I just want to change my subdomain back to infinityfree subdomain, is that possible? Actually, I just want to backup the wordpress site, and some of the plugin settings I have there. But, right now, I have no idea how to access the wp-admin page.

Hi infiniblue,

If you wish to use IF subdomains again, the DNS record on the custom domain doesn’t matter and is not related (although you should have those configured correclty as well.)

Free subdomains are always configured to use IF NS, so what you need to do is to change the WordPress home_url to use the free subdomain instead. For the custom domain tho, you might need to remove A recrods and have CNAME records pointing to the subdomain instead.

If you have recently changed NS (within 2 weeks), then delay all modifications a week later so that everything is properly propagated before you attempt something new.

Cheers!

1 Like

Actually, deleting the NS records, and re-adding them seemed to have solved the problem!
Thanks for the help, guys.

3 Likes

I think that this is unrelated to your issue. And this isn’t true anymore nowadays, because you can use CNAME verification instead.

5 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.