Uploaded SSL certificate is not working

Hi there,

I just tried following this video: https://www.youtube.com/watch?v=l0Q1CiJWvo8 to get free certificates for my site. All went very well, but I think I made a mistake of generating a CSR before I started the process.

In SSL For Free, I first tried getting a certificate without entering the pre-generated CSR (because I wanted to get a cert for www as well). That worked OK and I got a private key and a cert. I uploaded both successfully in cPanel, but both my browsers and SSL Checker still say the certificate is not valid.

I then tried to get another certificate from SSL For Free, this time using the CSR. SSL For Free did generate it for me, but I could not upload it in cPanel because the private key was not matching. I tried this twice (also with regenerating the CSR), both times with the same result.

I finally tried parking the domain back on ns1(and 2).epizy.com, but that didn’t help either.

I’m stumped now and have no idea on how to proceed. Does anyone know how I can resolve this?

Hi and welcome to the forum
your domain name (URL) ?

if it helps - (click me)

Hi , thanks for replying! The site is at meliandkarol.info.




Oh wow. Must have been taking longer than I anticipated. I feel very silly now—thank you and sorry for bothering you!

Hey there,

It looks like the certificate is not working again… Any idea why it could be?

It’s weird… Now it’s back on. Both my browser and ssl checker were reporting self-signed cert for a while, but now it seems fine. Is there something I did wrong? How can I make sure that this doesn’t happen again?

The SSL has gone down again on my site and I’m really puzzled. What makes it come and go? We have just made the website live and are beginning to share the link, so this is becoming a bit of a problem for us…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.