Upgrade to php 8.0.2

Please upgrade php 8.0.2 for my account because my forum doesn’t works without it. I use the latest flarum version. I installed composer on my own computer and then uploaded the files on the server.

Forum URL: My Flarum
Account Username: epiz_30876775

Flarum Version: 1.2.0

Sorry, but PHP 8 is not supported at this time. We don’t know when support will be added, as that is up to iFastNet, not us.

PHP 8 still has some vulnerabilities, and is not completely stable yet.

If I remember correctly, it is supported on premium hosting.


Can i bypass this message without having to upgrade my hosting plan? I think there is a composer setting ignore-platform-reqs.


Whatever you are trying to install NEEDS PHP 8 to run, if you don’t give it PHP 8, it is not going to run correctly, or run without severe vulnerabilities.

1 Like

Then what i can do? I need additional extensions for my forum.

A. Use different extensions
B. Use older versions of said extensions
C. Find a host that has PHP 8 (You are going to have to pay)

1 Like

I want to fake the php version but i don’t know how on InfinityFree. Config - Composer

How much of NO do you not understand?

1 Like

But i don’t care i just want to run my forum without freeflarum.


Just note that myself (And about 99% of the knowledgeable online population) are not going to help you put your own site in danger.

1 Like

It’s not going to put my site at a risk because i have cloudflare end-to-end encryption that auto-hiddes sensitive content from my site.

He’s referring to the vulnerabilities that PHP 8 may have.


But i want to use the current php version and bypass the composer error message.

As I already stated, you cannot do that. The application is setup for PHP 8. The server is setup for PHP 7. Even if you override composer, it will not work properly because the plugin needs PHP 8, and the server does not have it.

You will still be at risk. Cloudflare does not prevent XSS, SQL-inqection, ect.

1 Like

It works without php 8.

Then why is it urgent that you have PHP 8.0.2 support? If it works without PHP 8, you would not be getting any errors.

Composer forces me to get php 8 but i don’t need it.

Composer requires it because the plugin does. Note the text Your composer dependencies require a PHP version ">=8.0.2.

1 Like

Do you have PHP 8.0 or higher on your own computer? Because if so, that’s likely the problem.

If you run Composer with PHP 7.4, then Composer will try to fetch older versions of software that do support PHP 7.4. As long as Flarum itself, and the dependencies, don’t require minimum versions of software that require PHP 8, you can still run it on PHP 8 this way.

Our hosting doesn’t have PHP 8 yet at this time. PHP 7.4 will likely be replaced at some point with the then-latest version of PHP 8. However, not all software supports PHP 8 yet. For example, IonCube loaders for PHP 8 are still a work in progress, which means all software with IonCube encryption cannot be used on PHP 8 yet.

1 Like