Updating failed. the response is not a valid json response

Username (e.g. epiz_XXX) or Website URL


Error Message

updating failed. the response is not a valid json response

Hi read another post I can’t seem to fix this
I tried everything any suggestions

tried classic editor
changing POST names saving multiple times
I have this issue I do have SSL but this issue came when I installed my WordPress

Other Information

it’s happening when I update a post upload media or images anything everything loads slowly sometimes have to refresh 2-5 times before I can save or before it loads correctly

also when I enter my URL for example https://www.nginike.ga
then my home page redirts 3 times to
then myhomepage address is https://www.nginike.ga/?i=3
why is the ?i=3 i don’t want it there


Can you please check your browser’s developer tools to learn more about what’s actually being sent? Does the Console show anything? Can you find the request in the Network tab and see what’s actually being returned?

You can’t remove it, but you may be able to prevent some of the excess redirects.

Normally, it should only redirect once. But if you have separate redirects for example to redirect you from HTTP to HTTPS, and from non-www to www, this may cause these additional redirects.

And if there are problems with the cookies of your browser, it may also cause these extra redirects, because you’ll be redirected if a security cookie is missing.


thank you


please explain a little bit more should i click the console tab while im in my post sec) tion??when in developer mode?


Username (e.g. epiz_XXX) or Website URL


Link To Original Post

Error Message

Updating failed JSON respons

Other Information

I know I am most probably should not make another post but it does not want me to edit

so after digging around I noticed I get this error with a health check.

is this why I get the json error please help me I am trying to get my post up for 4days.

Actually this error is from root/server side.
Maybe @Admin must tell about this to iFastNet to install/setup CA Cert. correctly on the server.
1.) For Debian/Ubuntu server:
sudo apt-get install ca-certificates
sudo update-ca-certificates -f
Then check whether it exists on: /etc/ssl/certs/ca-certificates.crt
2.) Or download the latest cacert.pem: https://curl.haxx.se/ca/cacert.pem
Then check/add/edit this line on server php.ini file:

From non-root user side, you can solve this problem with some ways:
1.) Download cacert.pem file above (No. 2).
Then make .user.ini file inside your domain/subdomain htdocs folder. Its contents is same with a line above.
(I haven’t tried this whether it works or not in this free hosting)
2,) If you can modify your PHP file, in your case is WordPress file. Maybe it’s impossible?
To turn off SSL verification for cURL function (CURLOPT_SSL_VERIFYPEER, false).
But this is bad, because it allows your nice, encrypted stream of confidential data to be silently hijacked by a bad guy.

I found it was a time error, my server wouldn’t do a thing because of incorrect time, BIND DNS server was failing, apache failing, cURL failing, all because of the incorrect time.

But then again, I know the free hosting servers are CentOS, so it’s a bit different, especially vis-a-vis compiling source code e.t.c

Also, .user.ini doesn’t work

Since your old post was still open, could you just reply to the old post instead of creating a new topic about the same issue? If you’re still waiting for more information after a few days, just bump the topic instead of starting over.

Yes and no.

The CA chain on our servers is perfectly normal and up to date.

The issue is that our panel doesn’t support uploading CA chains, so most automated systems, including our servers, cannot verify these SSL certificates.

Turning off SSL verification would work around this.


Googling the error message confirms my suspicion: the problem is that your BROWSER does not get a valid JSON response from the SERVER. This is DEFINITELY NOT a problem with the SSL configuration in PHP, or with the API/loopback/whatever irrelevant nonsense the Health Check plugin complains about for no legitimate reason. And it may not be a PHP problem in the first place.

I had hoped the Console would show something useful, but apparently it does not.

So instead, could you see what the server actually returns?

To do so:

  1. Go to the WordPress admin page.
  2. Prepare your content but don’t hit the button which causes the error yet.
  3. Open your browser developer toolbar and go to the Network tab.
  4. Delete anything that’s already there, and enable Preserve Logs.
  5. Click the button which generates the error message.
  6. Find the first request that’s being generated.
  7. From the selected request, get a screenshot of the Headers panel and the Response panel.
1 Like

Hi all thanks for the help

so sorry for the late reply

So I woke up this morning tried going to the Network tab and get the logs tried updating and it seems as if the problem just went away by itself I don’t know why but as soon as I get to encounter the error I will definitely go to the Network tab and get the logs thanks for everyone’s help.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.