Unable to reach my website

So I have a website that is currently in development. Since the start, I have been able to access it without any issues. That, however, has now changed. After being away from it for about a week I tried accessing it with the very same address I have always used, and now it instead times out. On the CP for the website, it says that the site is still active and I am able to access the FTP host with an FTP client, but not the site itself. I tried accessing it on a different network, where it too times out. Pinging the address through the command prompt returned a 100% packet loss. What is wrong?

What do you see when you try to access the site through a browser?

Note that our servers block ping requests. Pings never work, even when your website is working great. A successful ping means a server is online, but a failing ping doesn’t really tell you anything.

When accessing via browser, I get ERR_REQUEST_TIMED_OUT. And it says that the page cannot be reached as it took too long to respond

Same but now its my users who use the site.

fun fact it should work on a other device for you try that!

I have tried on another device, but I could neither get through there

I’m sorry to say that the IP address your website is on ( is currently down for maintenance. We’re doing our best to get your website back online as quickly as possible.

It’s up now

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.