Unable to install thirty bees through Softaculous

Username (e.g. epiz_XXX) or Website URL

My username is epiz_30872917

Error Message

I get Error 404 when going to the homepage or admin panel (I haven’t set up anything besides those yet)


404 means file not found, so something got installed incorrectly. Can you try re-installing?

1 Like

Hmmm…may not work on free hosting

1 Like

I have checked your site and also see the 404 error. But I also see you’re using Cloudflare. Then I tried loading your website directly from your actual website IP, and then it’s working fine for me. No 404 page then.

So please double check your Cloudflare settings first. I think this issue is caused by having the wrong website IP in the DNS records. Please make sure that your base domain and the www subdomain are setup with an A record pointing to the IP address visible in the client area as the Website IP of the hosting account.

I also see some HTTPS redirects going on. Please make sure that your website is configured correctly to handle those. Cloudflare Flexible SSL is easiest to setup if it works, but many scripts don’t work well with it. It’s more secure and less error prone to generate and install a Self Signed SSL certificate on your site (you can get those through our Free SSL Certificates tool) and configure Cloudflare to use “Full” SSL mode. And avoid using “Automatic HTTPS Rewrites” at all costs, it tends to generate a lot of weird bugs.

After bypassing Cloudflare, your website still gave a 500 Internal Server Error for me, which means your website software is crashing. This article can help you get started with that: Http error 500

But for now, I would recommend focusing on the Cloudflare and HTTPS issues, because you’ll need that regardless of what software you’re going to use.


Wow, honestly I’m amazed at how fast and complete support is, thanks for the help, I already fixed the website IP on cloudflare, do I need to disable “Always use HTTPS” in Cloudflare aswell? I tried enabling the PHP directives to show the errors, but I still can’t see it, it just says HTTP Error 500 (I left it on in case you are able to see the error). After setting up the Self Signed Certificate from InfinityFree and setting up Full SSL mode on Cloudflare I get a Error 525 “SSL Handshake failed” (I left it on Flexible for now so you can debug the Error 500)

No, leave it - it is useful and desirable

For other issues, would be good to state your domain name
so that other forum members can check it and answer you.


I asked because Admin told me that I had to avoid using “Automatic HTTPS Rewrites”. My domain is coinvex.store

Automatic HTTPS Rewrites vs Always use HTTPS are not exactly the same thing (click links).

Or in short :

  • The Auto Rewrites changes the links on your site to be HTTPS if Cloudflare knows the destination supports HTTPS.

  • The Always Use HTTPS feature will redirect all HTTP requests for your site to your HTTPS address.


Admin, would you be able to help me with my issue?

You have Cloudflare setup correctly now, and I am able to connect to your website. However, the code on your website is not functioning properly, and is displaying a HTTP 503 error. Please follow the guide below for more details on this error, as well as how to fix it.


I already tried the guide and this is what happened:

If that is so, the cause could be your .htaccess (or any other code, for that matter) has some errors (likely) or your website is down (very unlikely).

If you have .htaccess code errors, your website will just display a HTTP 500 and no info.
Can you try commenting out all lines of your .htaccess code and see if it works?
HINT: .htaccess comments begin with #.

If it is not your .htaccess, it has to be some other malfunctioning code. Look through all of your PHP files for any misconfigurations, syntax errors, etc.



I have found multiple .htaccess files, one seems to be from InfinityFree that just includes links to solving most common errors (Like the one I’m having now) and the other is one that says that it is auto generated by thirtybees, so I don’t think it would be okay to edit it…

I checked your .htaccess file, but the display_errors option is set to on. However, this option can be overriden from PHP code, which means that even if you enabled this option through .htaccess, you won’t see any error messages.

The log folder in the site also doesn’t have any content.

It seems that PrestaShop/Thirty Bees expects the server to store error logs somewhere, but we don’t do that.

I did find a debug option in Thirty Bees though. In the file config/defines.inc.php is the line define('_PS_MODE_DEV_', false);. If you replace false with true, then save the file and reload your website, I do see an error.

The error I see then is:

Encoding::hexToBin() input is not a hex string.
in file vendor/defuse/php-encryption/src/Encoding.php at line 66 

Then, searching the web for that error points me to the following bug report: installation on Softaculous chokes · Issue #1046 · thirtybees/thirtybees · GitHub

So it seems that installing Thirty Bees through Softaculous is just broken. Softaculous ships a broken version of Thirty Bees. And the only way around it is to install the software by hand.


Thanks for the help, how can I start from zero again without any residue from the softaculous installation as to make a fresh install by hand? And also, last time I tried to install prestashop by hand it wouldn’t let me do it because it said the files were too large, I don’t know if the same will happen with thirtybees, but if it does, is there a workaround?

To remove all traces, you need to delete your hosting account and create a new one. To just remove the installation, login with FTP and delete everything inside the htdocs folder.

1 Like

Admin, I made a new account, put all the files manually, now I’m installing it but I’m stuck in the database configuration section, I’ve already tried creating a database named thirtybees and put the username and password from the SQL, please check on it.

For “Tables prefix”, remove the underscore, you should only enter what’s below


1 Like

Did not solve the problem, same error keeps showing up

This is definitely wrong. Check your account!