Unable to delete htdocs directory

Hello. I am unable to delete a certain folder off the server. When I try, it states that the folder is not empty and it is unable to process it. Not FTP nor Cpanel software helps with deletion.

Folder that need deleting:


Can you please help me with this?

You can’t delete htdocs in here, since the folder were act as “root directory”. Instead, you can delete everything inside it.

@anon55589970 The directory /htdocs does not exist or could not be selected, so the directory / is shown instead. I’m getting this error when I’m trying to open htdocs directory.

@anon55589970 I tried to delete htdoc from FTP FileZilla also. I’m getting this error 550 Can’t change directory to htdocs: Permission denied.

Hello @Sagar6906

Htdocs is locked folder.

Which means you CANNOT delete it.

Because “htdocs” is a folder for visible, public website directories and files.

And you put the viewable website content into it/

@bbot22 My website is not working and I want to remove everything and want to install wordpress once again.

@bbot22 I tried to add domain in another account but after installing wordpress when I’m trying to login I’m getting this error. The requested URL /wp-admin/ was not found on this server.

Your WordPress installation will always be under a children direction inside the “htdocs” folder.

If htdocs folder has no folders, if you delete folders under htdocs folder then go to Softaculous Script Installer and just install WordPress again under main directory. No Sub-directories.

@bbot22 I did. Still I’m getting same error. http://crazytees.store/wp-admin/ . My domain is crazytees,store

@bbot22 I’m getting this error. Not Found

The requested URL /wp-admin/ was not found on this server.

Your website and /wp-admin/ directory is fully accessable from my device.

Therefore it is installed, mark this reply as solved.

Why I’m not able to access?

Have you recently tried to change folder permission to htdocs?

I remembered that there was some kind of “deadlock” because of permission config being below 5xx

@anon55589970 I’ve not changed permission and I’m not able to change the permission of htdocs directory. I’m getting the error permission denied when I’m trying to change the permission.

Ahh, missed your statement right there. This should be useful.

@Sagar6906 you need to force refresh (Ctrl + F5 in Google Chrome) the webpage, see if it loads the page.

@anon55589970 I’m trying again and again. I tried in internet explorer also but still same issue.

That error page is not from our servers. It says Apache 2.4.29 running on Ubuntu. We don’t run Ubuntu and we don’t run that specific version of Apache.

Your website is working fine from here and your DNS settings look OK. Do you experience this issue on other devices. Have you edited the hosts file on your computer before?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.