My website URL is: http://quartzactually.co.uk/

What I’m seeing is: I can send emails but not receive

My MX records on infinityfree are set to mx epizy com
I have waited around a day for propagation
An email I sent TO my domain bounced with an error:

From the KB article “How to set your MX record”:

If the MX records shown does not match what’s in your control panel, please check:

  • Has the DNS fully propagated? DNS changes (including MX records changes) can take a few hours to become effective.
  • Does your domain use InfinityFree nameservers? If you are using third party nameservers, like Cloudflare, you must configure your MX records through the DNS management area of your DNS provider.
  • Are you using the control panel Cloudflare integration? A known issue of the control panel Cloudflare integration is that it breaks MX records (as well as custom CNAME records and subdomains). To receive email, you must disable Cloudflare on your domain name.

Ok, so it seems cloudflare was the problem. Is there any known workaround or anyway to fix this issue?

If you want to use Cloudflare while still receiving emails you will want to sign in to the Cloudflare dashboard and, after 48 hours, add the domain again on the Cloudflare account, changing the nameservers to their ones on your domain registrar’s nameservers management panel.

Sounds good! So I assume everything else would remain the same like I wont have to change host?

I assuming doing it through cloudflare directly is more of a “manual” way of doing it rather than through cpanel?

Yes, it’s more of a “‘manual” way to use Cloudflare, instead of using the cPanel integration for it. And every thing should be the same like you did never change host before.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.