This file type is not permitted for security reasons

Username (e.g. epiz_XXX) or Website URL

Error Message

Sorry, this file type is not permitted for security reasons.

Other Information

Recreate for

Even after adding define(‘ALLOW_UNFILTERED_UPLOADS’, true);, still doesn’t work. I’m trying to upload webp files btw (as PageSpeed recommends it.)

It could be due to this…

The file type is not allowed

Certain file types, like .exe files, are blocked on InfinityFree for security and fair usage limitations. Regular website files are allowed, but other files may be blocked.

If you would like to offer something for download or embed a video in your website, please use a specialized file sharing service or video streaming service for that instead.


Screenshot from 2021-01-23 13-04-58
Not quite. I try to upload one webp file, and it’s not auto-deleted.

So it is a particular name. Maybe renaming will help?

Where do you see this exactly?

In WordPress’ Media Library

OK, that explains. Googling the error message tells me that this message is generated by WordPress. This is not a hosting restriction, it’s entirely a security constraint within WordPress.

This article I found lists a couple of other options you could try:


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.