The .htacces redirect only works for the main site

My website URL is:

What I’m seeing is: In the main page i have ssl protection, but when i click on Bejelentkezés (Login) I get redirected to the right site, but without any ssl protection.

Additional information: Here is my .htaccess file. Did I need to put this in all the folders to work correctly?

RewriteEngine On
RewriteCond %{HTTP_HOST} ^sbcraft\.ml [NC]
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$$1 [R=301,L]

If you use Cloudflare it’s better to enable “Always Use HTTPS” from the Edge Certificates page of the SSL/TLS section of the Cloudflare dashboard for your domain.


I’m using the cpanel cloudflare service. I didn’t find there anything for https

Hi there,

You need to go to the Cloudflare dashboard to be able to enable “Always use HTTPS” and other features that cloudflare has to offer. Just use your InfinityFree credentials to login to their dashboard, it should work, if not manually reset your password, you should be able to see “forgot your password?” in their login page.

Since you are using the cloudflare integration in the vPanel then you will have limited features like you can’t be able to edit your DNS directly in Cloudflare.

Hope this helps!


Select “SSL/TLS”, then “Edge Certificates” and the option should be the second on the page.


Thanks for the help guys. :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.