The domain is taking more time to complete global propagation

Your site forces to use SSL/HTTPS connection.
Have you read this announcement?

The solutions:

  1. Remove HTTPS setting from your site. So, just use HTTP connection.
    or
  2. Add your own SSL certificate on your cPanel hosting (SSL menu) for your site.
    You can also make it for free using this new feature:
    New Feature: Free SSL for own domains!
3 Likes