The certificate you have entered does not match the current private key

My username is epiz_30085382

Every time I attempt to install an SSL certificate, this error shows up: The certificate you have entered does not match the current private key.

I suspect this is because I was using a self signed certificate prior to this error, and it was fine, however the
untrusted message from most browsers made me decide to go with a different certificate. I tried to install as usual however I still have the same private key from before. Would the cause be that my private key is still linked to the old self signed certificate? I am sorry if I am not making sense I only know programming.

Are you using to get your certificate? What are you using (GoGetSSL, ZeroSSL, LetsEncript) for the certificate? Have you completed the CNAME checks yet?

Thank you for replying. I used ZeroSSL, and yes, I correctly completed the CNAME steps. I was told by the program that the CNAME step was complete and it gave me my certificate and private key. Also just to clear up some potential confusion, yes, I used the private key that ZeroSSL gave me and yes, I used the correlated certificate.

This can happen if you don’t press “Upload Key” once you paste in your new Private Key.

1 Like

I tried using upload key before uploading the certificate, and I tried using upload certificate after, so I believe that is not the cause.

You may need to re-create the certificate as a last resort. Best of luck to you!

1 Like

Thank you I will try that.

Sorry let me clear up some more things. The SSL tool was working as usual, however I wanted to switch SSL providers, and upon doing that I was not able to install the new certificate.

Try this:

Delete everything from the SSL section from the control panel and log out.

Log back in and verify that all the SSL boxes in the control panel are empty.

Copy the private key from to the control panel and click “Upload Key”.

Reload the control panel.

Copy the certificate key from to the control panel and click “Upload Certificate”.

Reload the panel and ensure nothing disappeared.

Clear your cache.

Load your website using HTTPS.

Let me know if it does not work!

Edit: thanks @KangJL for pointing out I had the entire thing backwards.


This will definitely not work.

Private key should be installed followed by SSL cert

I have checked this and it seems very strange.

The private key you have uploaded matches the private key of your ZeroSSL certificate in the client area. But the SSL certificate shown in the client area actually doesn’t match the private key shown right beside it.

I have no idea what happened here. Maybe something went wrong in the client area code, maybe something went wrong at ZeroSSL. I really have no idea.

It also seems like two certificates have been reported by ZeroSSL, but none of the certificates matches the private key in the client area: |

I’ve never seen this before.

The only thing I can recommend right now is to simply request a new certificate. Hopefully it will work correctly this time and give you a correct key and certificate.


Try using LetsEncript or GoGetSSL.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.