Subdomains hidden?

Username (e.g. epiz_XXX) or Website URL

(please specify the website or account you are asking about)
epiz_25931964. Website:

Error Message

(please share the FULL error message you see)
I don’t get an error message, what happened is that today I wanted to further develop my website which will serve as an archive for a game’s versions (I have been granted full permission to do this). I opened cpanel and navigated torwards Monsta. My subdomain folders aren’t appearing, even though I do have the subdomains registered to and the subdomains are also accessible.

Other Information

(other information and details relevant to your question)

Hello there,

What do you mean exactly? I’m confused of what subdomain you’re talking about but if you’re looking for the folder of your subdomain “”, then it is the /htdocs folder you’re looking for.

no, I mean that I have other subdomains, but their respective folders have completely dissappeared, I can still access the websites but I can’t edit them because they don’t show up in Monsta FTP

Just to make sure, when you created those subdomains were you able to access the folders and then it just dissapeared or there was no folder to begin with?

yes, I was able to access the subdomain’s respective folders and edit the index.html files that I created within them

I’m not sure why that would happen but since I can’t check your account for you then I can only suggest you to delete and create those subdomains again.

If you don’t have a backup of the files in those subdomains on your local drive then I would wait for Admin to verify wether the respective folders of your subdomain does not exist.

Also have you tried using an FTP client? Try using one.
You can use the following:

  • Filezilla
  • WinSCP

ok, I’ll try to use one when I can (it’s 2 A.M. here), I’ll update you if I find them/don’t

It doesn’t let me connect to the server, it says ‘could not connect to server’, I’ve provided the correct credentials, what is going on?

Status: Connection attempt failed with “ECONNREFUSED - Connection refused by server”.


Please refer to this Knowledge Base article for that:

Just make sure you are using your FTP login credentials and not your Client Area credentials since the two are different.

I’ve connected to the server using FileZilla, the subdomains still not appear

Well might wait for Admin to check your account for you.

1 Like

Got it.

It appears that the hosting volume your website is on is currently in read only mode. This is likely the result of the migration from HDD to SSD storage. Because of this, any file and directory changes don’t take effect.

If you try again tomorrow, you can either create the subdomain directory by hand (it should be <subdomain>/htdocs) or just remove the subdomain and add it again to create the directories.

I’m sorry for the inconvenience caused by this right now, but it was either this or your website would be down entirely during the migration. And we’re seeing 10x performance increases on migrated websites, so it’s worth the wait!


I’ve tried to create a folder just now, it showed the following error message:

Error! There was an error creating the FOLDER: Error during FTP MAKE_DIRECTORY_OPERATION, permission denied at:

I have decided to delete the subdomains off of the account, but they are still active

From what I know is you can’t create a subdomain using Infinityfree sub domain. Hmmm?

Please note that I said:

The same reason that the hosting platform didn’t create the directories also means that you cannot create the directories. If you try now, it should work.

And the same reason that the hosting platform didn’t set up domains correctly also means that it didn’t remove accounts correctly.

So, next time, if someone esays:

Then please don’t start pressing buttons right away hoping to making things better.

1 Like

I deleted all of my subdomains and started again, after that Monsta FTP wouldn’t let me log in, I managed to fix the issue by creating a new account and removing all domains relating to it, it’s weird, but at least I can login now

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.