Step 3: Set up DNS Records for still in not ready

I have Set up DNS Records for domain and against current destination it is showing as not ready. Is there something pending to be done?

Since you did not fill up according to template, I guess you are limited by this

or this


Are you talking about SSL? Note that it can take up to 72 hours for DNS records to propagate.


Yes SSL record (Let’s Encrypt), it is more than 72hrs now but still it is showing not ready.
DO i need to delete other certificates like Self Signed (not trusted) is that something blocking it?

As you can see in the client area, the Current Destination of the CNAME record doesn’t match the destination it should have. So the solution is very simple: delete the current CNAME record for the _acme-challenge subdomain (the ones that end with and replace it with the value shown in the client area.

Also, please note that our nameservers are and The nameservers do not exist. Please make sure you don’t have broken nameservers on your domain as it can also impair the functionality of your website and prevent you from getting the SSL certificates.


Hi @Admin
My use case is to setup custom url for my e-commerce website. As part of this i need to do certain configuration. For this to work,my domain name should point to as its CNAME target .

If i will have to replace
with the cpanel value, my configuration will not work

How do we achieve this?

Simple: by having two CNAME records on your domain:

  • One for the _acme-challenge subdomain with the value we tell you to use in the Free SSL Certificates menu.
  • One for the customer subdomain with the value pointing to the the value Salesforce tells you to use.

Pointing the _acme-challenge subdomain to the value from Salesforce isn’t necessary to make the customer subdomain work and makes it impossible for us to get an SSL certificate for you, so you don’t want to do that.

And if you’re going to host the customer subdomain with Salesforce, I strongly recommend to let Salesforce handle the the SSL for your domain instead of doing that through us.


Thank you for your support. I have performed the configuration as suggested.
I have created two CNAMES. Can you please verify if it is correct now?
Also, will it take 72hrs to get issued?

Hi @Admin
I created two cname record as suggested, but while trying to add domain on salesforce it is getting errored out as below

Make sure the domain name uses as its CNAME target and try again later. It presently uses as the CNAME target, which does not equal the expected value.

The _acme-challenge record is correct. Please don’t touch the record.

But for the Salessorce record, you have created records for, not The extra S in the CNAME record means it’s not taking effect.

For the Salesforce SSL certificate, you may need to add a CNAME record for the _acme-challenge.customer subdomain too with the value Salesforce says you should add.

A few other notes about your DNS settings:

  • You still have set up as nameservers on your domain. These nameservers are still invalid, so please remove them.
  • If you want to host a subdomain with Salesforce, then please do not add it to your hosting account as Subdomain. That’s only if you want to host that subdomain with us, and it may interfere with your DNS settings if you also try to host it elsewhere.

Hi @Admin

But under subdomain i created as customers and not customer.
So we should add cname record with extra “S” right?

Also somehow i am unable to edit nameservers on domain “” .So is it fine to use domain and subdomain from infinityfree itself like the one i created “”.If i can use “”.What will be two cname records?

I just need one proper domain and subdomain to try out my usecase.


But under subdomain i created as customers and not customer.
So we should add cname record with extra “S” right?

Also somehow i was able to edit nameservers on domain “” .Does it reflect correct now?
.Can we use domain and subdomain from infinityfree itself like the one i created “”.If i can use “”.What will be two cname records?

Also i was able to map custom domain on my site on salesforce , but now site is not opening

I just need one proper domain and subdomain to try out my usecase.

Sorry, no idea where I got the customer part from. If customers is the one you want to use, then all is good!

If you want to host the customers subdomain with Salesforce, please remove it from the Subdomains menu in our control panel. Only add a subdomain there if you want to host that website with us, not if you want to host it with Salesforce.

That’s indeed odd. Still, it would be good to try, because having broken nameservers may result in a variety of issues.

Eh… no, it doesn’t. Now it seems like the nameservers from the domain have been erased completely. So most likely nothing is working now.

I have no idea how this happened. Please check this with Freenom.

The Domain Checker in the client area is really useful for this, it checks your nameserver settings and tells you if they look good or not.


Thank You for providing the information. I am trying to get in touch with freenom team to fix nameservers.
But meanwhile, I wanted to check with you can I utilize the domain and subdomain created in infinity free such as “”? If yes could you please guide me on what should be cname records configuration to achieve the same use case?

I glossed over that part before because it’s not clear to me how exactly you want to use the subdomain.

If you want to use as you did, you can just do that. The same instructions apply pretty much, although the exact CNAME values will differ.

You get get free SSL from us for (just use the Free SSL Certificates system to get it). And you can host with Salesforce, but you’ll need to try with Salesforce to make sure that they also support it and which records you should use with it.


Hi @Admin

I was able to update nameservers on via Domain checker, everything looks fine

Still when i try to open [] . It gives me the below err

Some more information about my use case which might help you to guide me better .I have community url created via salesforce.When we create a community on Salesforce, by default the URL is going to be something like .Now we can change this to our own custom url such as or anything else.To achieve this salesforce gives 4 options as below

  1. Salesforce serves the domain over HTTPS, on Salesforce’s servers, using your HTTPS certificate
    2.Salesforce serves the domain over HTTPS using a Salesforce content delivery network (CDN) partner
    3.A non-Salesforce host or service serves this domain over HTTPS
    4.Temporary non-HTTPS domain

As per my understanding in my case since i have nameservers hosting of infinityfree i have to chose 3rd option.Also for 3rd option i see that salesforce suggest to add proxy forward url ,that is the reason under cpanel under redirects i have added the url "

Below is actual community url created by default from salesforce
which we want to change to or anything else.

The nameservers indeed look fine now, but the hosting settings do not.

For the third time: you must remove the customers subdomain from the subdomains menu. You want to host the domain with Salesforce, not with us, so you should not add it as a subdomain to your account. That’s only if you want to host the subdomain with us.

The reason your site doesn’t work is because this is the current DNS setup:

It seems Salesforce is directing your domain to the “non-Salesforce host or service”, where you entered our nameserver address. But our nameservers are not serving any web pages, so that’s why you get the Connection Refused error on the customers subdomain now.

Also, that option is not going to work at all with us, because we don’t allow or support proxy hosting on our service.

I think you’ll want option 2 instead, the “Salesforce CDN partner” option. Looking at the screenshot from this post, it means you will need to setup another CNAME record. But that’s not going to be a problem, just don’t touch other the existing records for or


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.