SSL redirection works only a short time

I have installed a SSL on my site and added the text to the bottom of .htaccess. This worked for a few hours and then the site reverted to not secure. I checked the .htaccess file and the text had gone. I re-entered the text and saved the changes. The site then displayed as secure with a padlock, again after a few hours the site shows as not secure.

Any ideas please

Make sure you are actually loading the HTTPS version. If you have an SSL certificate, you may benefit from HSTS. Read more here:


Do you have a CMS that’s rewriting your .htaccess file? Or maybe a plugin that does this?

If your website code is rewriting your .htaccess file and removing any manual changes, that would explains why your .htaccess redirection disappears.

I am not aware that I have a CMS or or plugin that is rewriting the htaccess file.

I saw some LSCACHE related entries, which I’m quite sure are created by a (misconfigured) plugin, as we don’t run LiteSpeed servers or LiteSpeed Cache.

I have the plugin WPsupercache running to speed up loading times, perhaps that is what you are refering to

Thanks everyone for your help. It looks like I have solved the issue. I use Wordpress and in settings/general, I changed the URL to https and the problem seems to have been solved

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.