SSL on www doesn't work


why the Zero SSL doesn’t work on the www domain?
With non www it works fine.

If I force to www by .htaccess there’s an error message about financial information.
Does anyone know how to solve it?

Kind regards.

As long as you create and install it properly, ZeroSSL certificates work on subdomains.


But it does not work.

All SSL certificates we provide are valid for the base domain and the www subdomain, and when installed, are valid for both domain versions as well. If it’s not working for you, then something somewhere seems to have gone wrong.

Could you please share your domain name so we can have a look? If we know the domain name, there are quite a few checks we can run to see what’s wrong.


Can I send you a private massage? Because I don’t want to post my URL because Google can see it.

Thank you.

Now it works on www. but non www is a error message.

I have checked both URLs and they both work fine for me. The non-www URL redirects me to the www version of the site, but seeing how the URL is accessed with HTTPS, it means the non-www domain has working SSL. So the SSL itself is working fine.

What exactly do you see on your end?


Thank you for your answer Admin.

If I enterhttps:// it shows error:

„The connection is not private - This website may pretend to be „THE NAME OF DOMAIN“ to steal your personal or financial information. Return to the previous page. I think it‘s a SSL problem. works fine.

Did set https://www. in Softaculous. Hope this is right. But the problem still exist.


That does sound like an SSL problem. But as I said, the non-www domain is using a valid ZeroSSL certificate.

Could you please try in Incognito Mode instead? Browsers may also cache old SSL data, and the usual browser cache clearing doesn’t clear that cache. Incognito mode is the only way to bypass all browser caches.


Yes it is. So many ppl have SSL issues here…
I always use private mode in Safari.

There is no website-data caches…

Yes, but the overwhelming majority is either caused by user error or something that’s entirely unrelated to SSL. The SSL system not actually working correctly is quite rare.

And checking your site again, it looks like it’s the former for your site.

Looking at the SSL certificate currently installed on your site, the certificate is only valid for the www version of your domain. The non-www version of your domain is not included in the certificate, which means some browsers will show an error because the certificate doesn’t match the domain name being opened.

Fixing this is extremely easy though: simply use our Free SSL Certificates tool instead. It contains many features that help making getting a correct certificate easy. One of those things being that it automatically includes the www and non-www versions of your domain in every certificate (in addition to automating the verification and installation processes).


I have tried free ssl tool on infinityfree, but the message is: Current Destination (no CNAME found) Not Ready if I want to add „

The CNAME is set.

With GetGoSSL it works fine now.
The last error is my favicon with realfavicongenerator.
Also WP Optimize shows SSL cURL error. Don‘t know why.

Like it says below the table: it can take a few hours for the change to take effect. Especially if the automatic installation says there is nothing to set up.

What are you trying to do and what exact errors do you see?


I want to activate Jetpack. I deleted via FTP, uploaded again but can not activate it.

I still don’t understand it. First you’re having a problem with WP Optimize, now with Jetpack. And it’s still not clear to me what the issue actually is.

Although I will say that Jetpack probably won’t work here due to this security system, but there is also little benefit to it in my opinion.


Yes, Jetpack still doesn’t work. That’s why I use WP Optimize for website caching. In the WP Optimize Gzip compression settings I got the error message: cURL error 60: SSL certificate problem: unable to get local issuer certificate. Jetpack worked well for me, that‘s why I wanted to install Jetpack again.

Our servers already gzip encode any content sent by your site. I don’t know why WP Optimize needs to use cURL for this, but I can tell you that enabling gzip yourself is unnecessary because your website will be compressed regardless of what you do.

So if WP Optimize works fine except for this feature, I don’t see any reason why you can’t keep using WP Optimize for the features which do actually have effect.