SSL on free subdomain

I am trying to set up SSL on a free infinityfree subdomain. I’ve not done this before and am a little out of my depth :slight_smile:

I have just received the email saying that:
“your free certificate has just been issued”.

Following the instructions as best as I can, I’ve gone to the SSL/TLS page clicked on ‘configure’, uploaded the private key that was generated previously, and then uploaded the certificate I received via the email link.

However this just throws the error:

“The certificate you have entered does not match the current private key.”

Several attempts resulted in the same error.

Any help please?

Welcome. This issue is caused when you try to upload a Certificate that doesn’t match the Private Key.

Please try it again in this order:

Paste the Private Key in the correct section, and click Upload Key. Then paste the Cert in the Certificate Box and click upload Cert.

If you are still getting the same error, you may have to generate a new SSL Certificate.

The article below provides a bit of information about this kind of error.

1 Like

OK, you can ignore my post. I tried it one more time and it worked! Go figure!

Now I just need to work out why images are not showing up.

1 Like

Thanks, I will read through that. I have just got it working now!


Whats your website URL? It could be to do with Cache.

There is no content yet, just finding my way around at the moment :wink:

Ah, starting off we WordPress I see. You said images aren’t showing up? Is that on a specific page or related to something else?

The images weren’t showing on a plain html document previously. Installing WordPress made no difference. They show up in preview but not on the site itself.

What were you putting as the image URLs?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.