SSL not working

Username (e.g. epiz_XXX) or Website URL


(please specify the website or account you are asking about)

Error Message

(please share the FULL error message you see)

In firefox, I see the following error:

Secure Connection Failed

An error occurred during a connection to Peer reports it experienced an internal error.


The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem.

I have configure the free SSL and uploaded it under the TLS/SSL section in the panel.

Other Information

(other information and details relevant to your question)

I also tried another free cert and saw the same error.

I also added the certificate again under TLS/SSL sections after the thread was updated as all working, but looks like this one is a different issue and is still not fixed.

1 Like

Can you show a screenshot from the SSL screen in the client area and from the SSL/TLS in the control panel?

1 Like

Please send a screenshot of the lookup of the SSL

Linking this to my issue, seems identical. My reported error is different only because my user agent is Chrome. When I tried in FF I got the same error as the OP.

1 Like

I merged your topic here with all the other “My SSL certificate does not work” topics. Please don’t ask the same question repeatedly.