SSL is not working properly on my wordpress/jetpack

Hi there, There are similar questions asked but I was not able to fix my issue. I’ve bought the domain name and SSL certificate from namecheap for where I installed wordpress. I added the cname in cpanel, got the CSR and used it to get a certificate from namecheap, I’ve uploaded it to my cpanel, waited few days but It still did not work. I then used the Really Simple SSL plugins which did not work at start, tried it after few days again and started working. I tried to setup Jetpack but it would not work because of SSL issue: Error says “cURL error 60: SSL certificate problem: unable to get local issuer certificate”. Similar error was showing when I tried to use Really Simple SSL at the start.
I contacted namecheap, they said they done their part and I need to contact my hosting. Is there something I’m doing wrong or mis-configured? I’m on free hosting plan. Any help would be appriciated!

The problem is that OpenSSL doesn’t recognize your certificate’s Certificate Authority’s (CA) certificate
Unfortunately, Chain & root certificates are only available to premium plan.
You can use CloudFlare instead (see below guide)


Your SSL certificate was installed successfully. If you navigate to, you’ll already see a green lock in the address bar. So this is definitely not something Namecheap can help you with because your SSL is fine.

Which means all that’s left to do is to redirect traffic to HTTPS.

The Really Simple SSL plugin works very well for that. But not all features of that plugin can be used, notably the Mixed Content Fixer doesn’t work with our SSL certificates. Fortunately, the Mixed Content Fixer is not required if your SSL just works, which it seems to do in your case.


Welcome, this answer provides a way to fix Jetpack SSL Issues:


SSL certificate only works when I enable the Really Simple SSL, when I deactivate that, the site become non https! But the issue I’m having I think is something to do with the actual JetPack plugins or as others mentioned OpenSSL. Will need to look into that!

Thank you for the reply.! I’ve tried doing the followings, added the line to wp-config.php but still did not solve anything. I still get the same error! :frowning:

I have implemented what was asked in that thread and got the website working from cloudfare. But still have the same Jetpack error while trying to approve it. I’m not sure what I’m doing wrong here!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.