SSL : How to configure 123-reg to go https

I tried to go “https” with a free SSL certificate but I am struggling with the configuration in connection with 123-reg.

I followed Step “1: Setup DNS Records for txtlock[dot]co[dot]uk” and went to 123-reg[dot]co[dot]uk to add the following details in my DNS Management / Advanced DNS:

DNS entry: _acme-challenge
Destination / Target: rzo67vi[…]

DNS entry:_acme-challenge.www
Destination / Target: hyvejo[…]

So far so good,

But when I click on “Refresh DNS Status” (Infinityfree / SSL Certificates) I get the following Error: The CNAME record is not pointing to the right destination. The required CNAME record could not be found.

I am aware that it can take up to 24 h for all the changes but I waited over 1 week and I still get this error :frowning:

Can anyone help?

Thanks in advance…


I did a DNS lookup, and could not find any CNAME records; that means that you haven’t added any or they are misconfigured.

Well, there are two issues here.

First of all, you need to set the CNAME records with your DNS provider. This can be your domain name provider, but it doesn’t have to be. It could also be your hosting provider or another provider.

In your case, the domain is using our nameservers, so we are the DNS provider for your domain. That means you need to set the CNAME records through our panel.

However, this will not work right now because you are using our Cloudflare integration. If you want to set these CNAME records, you have to disable our Cloudflare integration first. But if you’re already using Cloudflare, why not just use their SSL certificates?


Hello Admin - thank you for your reply. I really appreciate it :slight_smile:

I think I go with the Cloudflare integration. I registered with Cloudflare and both of my website ( and are now listed and active.

Question now: What to do next?

Both sites are now set to “Your SSL/TLS encryption mode is Flexible”.
What do I have to change / set to get my https for both of my sites?

Thanks in advance


1 Like

Hello Admin - just a quick update:
Problem is fixed.

Just checked as well as and both are now served with https! I also changed the traffic from http → https!

All good.

Kind regards


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.