Ssl handshake failed for subdomains

Username (e.g. epiz_XXX) or Website URL

Error Message

ssl handshake failed

Other Information

everything is working with ssl but subdomains are not working, my website is working fine with ssl.
i am using cloudflare

I had this issue a few days ago until @Ergastolator1 sorted it out. Just go to your client area and copy your ip address. After that, add an A record in Cloudflare. The name should be the subdomain part and paste the ip on the box next to it. That’s it!

Step 1:

Step 2:

The “Error 525 - SSL handshake failed” message means that Cloudflare didn’t find a valid SSL certificate on the backend server. This happens if you’re using “Full” or “Full (strict)” SSL mode without a certificate installed on your hosting account.

There are two ways you can fix this:

  • You can switch to Flexible SSL, which bypasses the need to have any SSL certificate on your hosting account.
  • You can acquire and install a valid SSL certificate for your subdomain and install that on your account.

If you’re currently using an SSL certificate provided by our tool, please note that it is only valid for and Other subdomains are not covered, and you’ll need to get and install separate SSL certificates if you want to protect those.


Can I use cloudflare “Full” with Lets Encrypt free ssl, will it work then?

yes, indeed, like me.
First, in control panel, you must have an any SSL (Lets Encrypt is popular).

Then when there is an SSL in your control panel, you should then enable SSL “FULL” in the cloudflare


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.